summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-21 16:46:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-21 18:13:19 +0200
commit2e6870c4d0527333d237d7ca94f8d3d783c9f082 (patch)
treed60001d81c6f1ee1ce7f4a7e354a1d20efa5cd15 /media-libs
parentmedia-sound/guitarix: add missing PYTHON_DEPS (diff)
downloadgentoo-2e6870c4d0527333d237d7ca94f8d3d783c9f082.tar.gz
gentoo-2e6870c4d0527333d237d7ca94f8d3d783c9f082.tar.bz2
gentoo-2e6870c4d0527333d237d7ca94f8d3d783c9f082.zip
media-libs/qimageblitz: Fix build with >=dev-util/cmake-3.15
Closes: https://bugs.gentoo.org/690360 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch11
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild9
2 files changed, 17 insertions, 3 deletions
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch
new file mode 100644
index 000000000000..da962cd1c95b
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2017-03-15 00:31:04.000000000 +0100
++++ b/CMakeLists.txt 2019-07-21 16:39:14.365729343 +0200
+@@ -14,6 +14,8 @@
+ set(CMAKE_AUTOMOC ON)
+ find_package(Qt5Core REQUIRED)
+ find_package(Qt5Gui REQUIRED)
++ set (CMAKE_CXX_STANDARD 11)
++ set (CMAKE_CXX_EXTENSIONS OFF)
+ else()
+ find_package(Qt4 REQUIRED)
+ # properly set up compile flags (QT_DEBUG/QT_NO_DEBUG, ...)
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
index a9370aa19ecc..bbbf7fcfea31 100644
--- a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils
@@ -21,7 +21,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-gcc.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-gcc.patch"
+ "${FILESDIR}/${P}-cxx11.patch" # bug 690360
+)
src_configure() {
local mycmakeargs=(