summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-02-20 22:04:46 +0100
committerSam James <sam@gentoo.org>2021-06-22 19:28:46 +0100
commitf4d4cfa808e4fe991fa1024349f58f90e084f3df (patch)
tree2228268f09ac0f653805a8587b45e9846022597a /media-plugins/vdr-rssreader
parentmedia-plugins/vdr-rssreader-2.2.1: update SRC_URI, new EAPI (diff)
downloadgentoo-f4d4cfa808e4fe991fa1024349f58f90e084f3df.tar.gz
gentoo-f4d4cfa808e4fe991fa1024349f58f90e084f3df.tar.bz2
gentoo-f4d4cfa808e4fe991fa1024349f58f90e084f3df.zip
media-plugins/vdr-rssreader-2.4.0: fix QA_FLAGS
add QA_FLAGS_IGNORED like on all other media-plugin/vdr-* Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/19563 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-rssreader')
-rw-r--r--media-plugins/vdr-rssreader/vdr-rssreader-2.4.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/vdr-rssreader/vdr-rssreader-2.4.0-r1.ebuild b/media-plugins/vdr-rssreader/vdr-rssreader-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..ff844e5596eb
--- /dev/null
+++ b/media-plugins/vdr-rssreader/vdr-rssreader-2.4.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+MY_P="vdr-plugin-rssreader-${PV}"
+
+DESCRIPTION="VDR Plugin: RSS reader"
+HOMEPAGE="https://github.com/rofafor/vdr-plugin-rssreader"
+SRC_URI="https://github.com/rofafor/vdr-plugin-rssreader/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=media-video/vdr-2.4.0
+ >=dev-libs/expat-1.95.8
+ >=net-misc/curl-7.15.1-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.0-gentoo.diff"
+)
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-rssreader.*
+ usr/lib64/vdr/plugins/libvdr-rssreader.*"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/rssreader
+ doins "${S}/rssreader/rssreader.conf"
+}