summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-12-03 23:33:47 +0000
committerMarek Szuba <marecki@gentoo.org>2021-12-03 23:39:32 +0000
commita7b4a66e768c31054e4fbe73ea1ce35b2742419c (patch)
tree2047c01b304cf481a94081676a7f2653cda24de5 /media-radio/tqsl/tqsl-2.5.9.ebuild
parentnet-im/signal-desktop-bin: remove clone3 USEdep for 5.25.0 (diff)
downloadgentoo-a7b4a66e768c31054e4fbe73ea1ce35b2742419c.tar.gz
gentoo-a7b4a66e768c31054e4fbe73ea1ce35b2742419c.tar.bz2
gentoo-a7b4a66e768c31054e4fbe73ea1ce35b2742419c.zip
media-radio/tqsl: add 2.5.9
Invoking long-overdue maintainer time-out on this one. For obvious reasons in light of the above, SRC_URI had to be updated and now points to the official upstream source tarball. Closes: https://bugs.gentoo.org/701704 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-radio/tqsl/tqsl-2.5.9.ebuild')
-rw-r--r--media-radio/tqsl/tqsl-2.5.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-radio/tqsl/tqsl-2.5.9.ebuild b/media-radio/tqsl/tqsl-2.5.9.ebuild
new file mode 100644
index 000000000000..22cc02985616
--- /dev/null
+++ b/media-radio/tqsl/tqsl-2.5.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake wxwidgets
+
+DESCRIPTION="ARRL Logbook of the World"
+HOMEPAGE="https://www.arrl.org/tqsl-download"
+SRC_URI="https://www.arrl.org/${PN}/${P}.tar.gz"
+
+LICENSE="LOTW"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/expat:=
+ dev-libs/openssl:0=
+ net-misc/curl:=
+ sys-libs/db:=
+ sys-libs/zlib:=
+ x11-libs/wxGTK:${WX_GTK_VER}="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.9-lib_suffix.patch
+)
+
+DOCS=( AUTHORS.txt INSTALL README )
+HTML_DOCS=( html/. )
+
+src_configure() {
+ setup-wxwidgets
+ cmake_src_configure
+}