summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2024-02-01 19:27:27 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-28 09:12:17 +0200
commit0d98f80e2a588522c5c810ddb123f9fb425e4556 (patch)
tree9b56727ec4d61fcbc85ad2eafd1ba615588f98b2 /media-sound/alacenc/alacenc-0.4.0.ebuild
parentnet-misc/tinyssh: revbump due to implicit-function-declaration fix (diff)
downloadgentoo-0d98f80e2a588522c5c810ddb123f9fb425e4556.tar.gz
gentoo-0d98f80e2a588522c5c810ddb123f9fb425e4556.tar.bz2
gentoo-0d98f80e2a588522c5c810ddb123f9fb425e4556.zip
media-sound/alacenc: new package, add 0.4.0
Package for encoding audio into the ALAC format. Required by media-sound/flacon. I take maintainership for this package. Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound/alacenc/alacenc-0.4.0.ebuild')
-rw-r--r--media-sound/alacenc/alacenc-0.4.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-sound/alacenc/alacenc-0.4.0.ebuild b/media-sound/alacenc/alacenc-0.4.0.ebuild
new file mode 100644
index 000000000000..d1e6d081f081
--- /dev/null
+++ b/media-sound/alacenc/alacenc-0.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Encodes audio into the Apple Lossless Audio Codec (ALAC) format"
+HOMEPAGE="https://github.com/flacon/alacenc"
+SRC_URI="https://github.com/flacon/alacenc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ dobin "${BUILD_DIR}/alacenc"
+ einstalldocs
+}