summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/alacenc/alacenc-0.4.0.ebuild')
-rw-r--r--media-sound/alacenc/alacenc-0.4.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-sound/alacenc/alacenc-0.4.0.ebuild b/media-sound/alacenc/alacenc-0.4.0.ebuild
new file mode 100644
index 000000000000..d1e6d081f081
--- /dev/null
+++ b/media-sound/alacenc/alacenc-0.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Encodes audio into the Apple Lossless Audio Codec (ALAC) format"
+HOMEPAGE="https://github.com/flacon/alacenc"
+SRC_URI="https://github.com/flacon/alacenc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ dobin "${BUILD_DIR}/alacenc"
+ einstalldocs
+}