summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/csound/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/csound/files')
-rw-r--r--media-sound/csound/files/csound-5.16.6-tests.patch90
-rw-r--r--media-sound/csound/files/csound-5.17.11-cmake.patch10
-rw-r--r--media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch20
-rw-r--r--media-sound/csound/files/csound-5.17.6-fltk.patch10
-rw-r--r--media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch20
-rw-r--r--media-sound/csound/files/csound-6.02-porttime-in-portmidi.patch30
-rw-r--r--media-sound/csound/files/csound-6.05-python.patch19
7 files changed, 199 insertions, 0 deletions
diff --git a/media-sound/csound/files/csound-5.16.6-tests.patch b/media-sound/csound/files/csound-5.16.6-tests.patch
new file mode 100644
index 000000000000..dd8b8ed289bc
--- /dev/null
+++ b/media-sound/csound/files/csound-5.16.6-tests.patch
@@ -0,0 +1,90 @@
+--- Csound5.16.6/tests/test.py.orig
++++ Csound5.16.6/tests/test.py
+@@ -6,9 +6,6 @@
+ import os
+ import sys
+
+-from testUI import TestApplication
+-from Tkinter import *
+-
+ parserType = "--new-parser"
+ showUIatClose = False
+ csoundExecutable = ""
+@@ -104,8 +101,6 @@
+ ]
+
+
+- output = ""
+- tempfile = "/tmp/csound_test_output.txt"
+ counter = 1
+
+ retVals = []
+@@ -124,7 +119,7 @@
+ retVal = os.system(command)
+ else:
+ executable = (csoundExecutable == "") and "../csound" or csoundExecutable
+- command = "%s %s %s %s &> %s"%(executable, parserType, runArgs, filename, tempfile)
++ command = "%s %s %s %s"%(executable, parserType, runArgs, filename)
+ retVal = os.system(command)
+
+ print "Test %i: %s (%s)\nReturn Code: %i"%(counter, desc, filename, retVal)
+@@ -136,24 +131,6 @@
+ testFail += 1
+ print "Result: FAIL\n"
+
+- output += "%s\n"%("=" * 80)
+- output += "Test %i: %s (%s)\nReturn Code: %i\n"%(counter, desc, filename, retVal)
+- output += "%s\n\n"%("=" * 80)
+-
+- f = open(tempfile, "r")
+-
+- csOutput = ""
+-
+- for line in f:
+- csOutput += line
+-
+- output += csOutput
+-
+- f.close()
+-
+- retVals.append(t + [retVal, csOutput])
+-
+- output += "\n\n"
+ counter += 1
+
+ # print output
+@@ -162,12 +139,7 @@
+ print "Tests Passed: %i\nTests Failed: %i\n"%(testPass, testFail)
+
+
+- f = open("results.txt", "w")
+- f.write(output)
+- f.flush()
+- f.close()
+-
+- return retVals
++ return testFail
+
+ if __name__ == "__main__":
+ if(len(sys.argv) > 1):
+@@ -176,6 +148,8 @@
+ showHelp()
+ sys.exit(0)
+ elif arg == "--show-ui":
++ from testUI import TestApplication
++ from Tkinter import *
+ showUIatClose = True
+ elif arg == "--old-parser":
+ parserType = "--old-parser"
+@@ -185,6 +159,8 @@
+ elif arg.startswith("--opcodedir64="):
+ os.environ['OPCODEDIR64'] = arg[14:]
+ print os.environ['OPCODEDIR64']
+- results = runTest()
+- if (showUIatClose):
+- showUI(results)
++ failures = runTest()
++ if failures > 0:
++ sys.exit(1)
++ else:
++ sys.exit(0)
diff --git a/media-sound/csound/files/csound-5.17.11-cmake.patch b/media-sound/csound/files/csound-5.17.11-cmake.patch
new file mode 100644
index 000000000000..388a043d57cf
--- /dev/null
+++ b/media-sound/csound/files/csound-5.17.11-cmake.patch
@@ -0,0 +1,10 @@
+--- Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
++++ Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
+@@ -29,7 +29,6 @@
+ allegrowr.cpp
+ Cell.cpp
+ ChordLindenmayer.cpp
+- cmake_install.cmake
+ Composition.cpp
+ Conversions.cpp
+ Counterpoint.cpp
diff --git a/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch b/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch
new file mode 100644
index 000000000000..ae07d41a63e3
--- /dev/null
+++ b/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch
@@ -0,0 +1,20 @@
+--- Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
++++ Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
+@@ -7,6 +7,7 @@
+
+ find_package(Boost)
+ find_library(MUSICXML_LIBRARY musicxml2)
++set(FLTK_SKIP_OPENGL true)
+ find_package(FLTK)
+ find_package(SWIG)
+ find_package(PythonLibs)
+--- Csound5.17.11/InOut/CMakeLists.txt
++++ Csound5.17.11/InOut/CMakeLists.txt
+@@ -56,6 +56,7 @@
+ find_library(COREAUDIO_LIBRARY CoreAudio)
+ endif()
+ if(USE_FLTK OR BUILD_VIRTUAL_KEYBOARD)
++ set(FLTK_SKIP_OPENGL true)
+ find_package(FLTK)
+ endif()
+
diff --git a/media-sound/csound/files/csound-5.17.6-fltk.patch b/media-sound/csound/files/csound-5.17.6-fltk.patch
new file mode 100644
index 000000000000..74b72689e889
--- /dev/null
+++ b/media-sound/csound/files/csound-5.17.6-fltk.patch
@@ -0,0 +1,10 @@
+--- Csound5.17.6/InOut/CMakeLists.txt
++++ Csound5.17.6/InOut/CMakeLists.txt
+@@ -148,6 +148,7 @@
+ if(USE_FLTK)
+ set(widgets_SRCS FL_graph.cpp winFLTK.c widgets.cpp)
+ make_plugin(widgets "${widgets_SRCS}" "${FLTK_LIBRARIES}")
++ include_directories(${FLTK_INCLUDE_DIR})
+ endif()
+
+ check_deps(BUILD_VIRTUAL_KEYBOARD FLTK_FOUND)
diff --git a/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch b/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch
new file mode 100644
index 000000000000..3f69a3795f04
--- /dev/null
+++ b/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch
@@ -0,0 +1,20 @@
+--- Csound5.17.6/InOut/CMakeLists.txt
++++ Csound5.17.6/InOut/CMakeLists.txt
+@@ -26,7 +26,6 @@
+ endif()
+ if(USE_PORTMIDI)
+ find_library(PORTMIDI_LIBRARY portmidi)
+- find_library(PORTTIME_LIBRARY porttime)
+ check_include_file(portmidi.h PORTMIDI_HEADER)
+ endif()
+ if(USE_JACK)
+@@ -116,9 +115,6 @@
+ check_deps(USE_PORTMIDI PORTMIDI_HEADER PORTMIDI_LIBRARY)
+ if(USE_PORTMIDI)
+ set(pmidi_LIBS ${PORTMIDI_LIBRARY})
+- if(NOT APPLE)
+- list(APPEND pmidi_LIBS ${PORTTIME_LIBRARY})
+- endif()
+ if(WIN32)
+ list(APPEND pmidi_LIBS ${CSOUND_WINDOWS_LIBRARIES})
+ endif()
diff --git a/media-sound/csound/files/csound-6.02-porttime-in-portmidi.patch b/media-sound/csound/files/csound-6.02-porttime-in-portmidi.patch
new file mode 100644
index 000000000000..1ef67a15c13d
--- /dev/null
+++ b/media-sound/csound/files/csound-6.02-porttime-in-portmidi.patch
@@ -0,0 +1,30 @@
+--- Csound6.02/InOut/CMakeLists.txt
++++ Csound6.02/InOut/CMakeLists.txt
+@@ -33,10 +33,6 @@
+ find_library(PORTMIDI_LIBRARY portmidi)
+ # include_directories(${PORTMIDI_INCLUDE_PATH})
+ # include_directories(${PORTTIME_INCLUDE_PATH})
+- if(WIN32)
+- else()
+- find_library(PORTTIME_LIBRARY porttime)
+- endif()
+ endif()
+ if(USE_JACK)
+ find_library(JACK_LIBRARY jack)
+@@ -126,15 +122,12 @@
+ elseif(WIN32)
+ check_deps(USE_PORTMIDI PORTMIDI_INCLUDE_PATH PORTTIME_INCLUDE_PATH PORTMIDI_LIBRARY)
+ else()
+- check_deps(USE_PORTMIDI PORTMIDI_INCLUDE_PATH PORTMIDI_LIBRARY PORTTIME_LIBRARY)
++ check_deps(USE_PORTMIDI PORTMIDI_INCLUDE_PATH PORTMIDI_LIBRARY)
+ endif()
+
+ if(USE_PORTMIDI)
+ set(pmidi_LIBS ${PORTMIDI_LIBRARY})
+ include_directories(${PORTMIDI_INCLUDE_PATH})
+- if(LINUX)
+- list(APPEND pmidi_LIBS ${PORTTIME_LIBRARY})
+- endif()
+ if(WIN32)
+ include_directories(${PORTTIME_INCLUDE_PATH})
+ list(APPEND pmidi_LIBS ${CSOUND_WINDOWS_LIBRARIES})
diff --git a/media-sound/csound/files/csound-6.05-python.patch b/media-sound/csound/files/csound-6.05-python.patch
new file mode 100644
index 000000000000..3e9ee857fe98
--- /dev/null
+++ b/media-sound/csound/files/csound-6.05-python.patch
@@ -0,0 +1,19 @@
+--- csound-6.05.0.orig/CMakeLists.txt 2015-04-26 03:06:22.941646148 +0800
++++ csound-6.05.0/CMakeLists.txt 2015-07-08 22:31:16.637995822 +0800
+@@ -41,15 +41,9 @@
+ set(PLUGIN_INSTALL_DIR "${LIBRARY_INSTALL_DIR}/csound/plugins-${APIVERSION}")
+ endif()
+
+-
+-execute_process (
+- COMMAND python -c
+- "import site, sys; sys.stdout.write(site.getusersitepackages())"
+- OUTPUT_VARIABLE PYTHON_MODULE_INSTALL_DIR
+- )
+-
+ set(JAVA_MODULE_INSTALL_DIR ${LIBRARY_INSTALL_DIR})
+ set(LUA_MODULE_INSTALL_DIR ${LIBRARY_INSTALL_DIR})
++set(PYTHON_MODULE_INSTALL_DIR ${REPLACE_ME})
+ set(LOCALE_INSTALL_DIR "share/locale")
+ set(HEADER_INSTALL_DIR "include/csound")
+