summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2018-02-17 12:59:53 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2018-02-17 12:59:53 +0100
commitcb700cf3a8b38490fc2a9e9368b8720045a2ea81 (patch)
treec1429af7f9f5b4b22a9a6e887305b89e2f401b7f /media-sound/lilypond
parentnet-analyzer/scapy: Fix distutils-r1 usage, drop eutils. (diff)
downloadgentoo-cb700cf3a8b38490fc2a9e9368b8720045a2ea81.tar.gz
gentoo-cb700cf3a8b38490fc2a9e9368b8720045a2ea81.tar.bz2
gentoo-cb700cf3a8b38490fc2a9e9368b8720045a2ea81.zip
media-sound/lilypond: fixed bug causing lilypond does not compile (programming_error does not return value)
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/files/lilypond-9999-programming_error.patch13
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/media-sound/lilypond/files/lilypond-9999-programming_error.patch b/media-sound/lilypond/files/lilypond-9999-programming_error.patch
new file mode 100644
index 00000000000..f2b85164a6e
--- /dev/null
+++ b/media-sound/lilypond/files/lilypond-9999-programming_error.patch
@@ -0,0 +1,13 @@
+diff --git a/lily/general-scheme.cc b/lily/general-scheme.cc
+index d25e6c9ef8..2fd2e4a4fa 100644
+--- a/lily/general-scheme.cc
++++ b/lily/general-scheme.cc
+@@ -275,7 +275,7 @@ LY_DEFINE (ly_protects, "ly:protects",
+ #if SCM_MAJOR_VERSION < 2 || SCM_MAJOR_VERSION == 2 && SCM_MINOR_VERSION < 1
+ return scm_protects;
+ #else
+- return programming_error ("ly:protects is not supported in Guile 2.1");
++ programming_error ("ly:protects is not supported in Guile 2.1");
+ #endif
+ }
+
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 27bfc06997d..e24a72ba576 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -22,6 +22,7 @@ SLOT="0"
LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
IUSE="debug emacs guile2 profile vim-syntax"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+PATCHES=(${FILESDIR}/$P-programming_error.patch)
RDEPEND=">=app-text/ghostscript-gpl-8.15
>=dev-scheme/guile-1.8.2:12[deprecated,regex]