summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-06-30 12:35:12 +0200
committerPacho Ramos <pacho@gentoo.org>2019-06-30 13:22:45 +0200
commit63c71bc43e8f10e5c3cfca31cf64716b00c34da6 (patch)
tree5de9c771bbcf82455d29cc082157da420862ed54 /media-sound
parentsys-kernel/git-sources: Linux patch 5.2-rc7 (diff)
downloadgentoo-63c71bc43e8f10e5c3cfca31cf64716b00c34da6.tar.gz
gentoo-63c71bc43e8f10e5c3cfca31cf64716b00c34da6.tar.bz2
gentoo-63c71bc43e8f10e5c3cfca31cf64716b00c34da6.zip
media-sound/pulseaudio-modules-bt: Add info about extra configuration needed
User will need to ensure that default.pa still loads needed modules, this is needed because as we need to build pulseaudio with USE -bluetooth to not collide, the newly generated default.pa file with remove that needed lines. See https://github.com/EHfive/pulseaudio-modules-bt/issues/33 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild30
1 files changed, 29 insertions, 1 deletions
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
index 23b537c2088d..3e6f061a1f3b 100644
--- a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
+++ b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit git-r3 cmake-utils
+inherit git-r3 cmake-utils readme.gentoo-r1
DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth (alongside SBC and native+ofono headset)"
HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -32,3 +32,31 @@ BDEPEND=""
CMAKE_MAKEFILE_GENERATOR="emake"
mycmakeargs=( -DFORCE_NOT_BUILD_LDAC=ON )
+
+DISABLE_AUTOFORMATTING="no"
+DOC_CONTENTS="
+After getting media-sound/pulseaudio merged without its bluetooth
+support (to not collide with this) you may have removed the loading
+of bluetooth modules in default.pa config file, leading to failure
+to use your bluetooth device (see
+https://github.com/EHfive/pulseaudio-modules-bt/issues/33).
+Please ensure you have this lines present in your /etc/pulse/default.pa
+file:
+
+.ifexists module-bluetooth-policy.so
+load-module module-bluetooth-policy
+.endif
+
+.ifexists module-bluetooth-discover.so
+load-module module-bluetooth-discover
+.endif
+"
+
+src_install() {
+ cmake-utils_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}