summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild30
1 files changed, 29 insertions, 1 deletions
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
index 23b537c2088d..3e6f061a1f3b 100644
--- a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
+++ b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit git-r3 cmake-utils
+inherit git-r3 cmake-utils readme.gentoo-r1
DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth (alongside SBC and native+ofono headset)"
HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -32,3 +32,31 @@ BDEPEND=""
CMAKE_MAKEFILE_GENERATOR="emake"
mycmakeargs=( -DFORCE_NOT_BUILD_LDAC=ON )
+
+DISABLE_AUTOFORMATTING="no"
+DOC_CONTENTS="
+After getting media-sound/pulseaudio merged without its bluetooth
+support (to not collide with this) you may have removed the loading
+of bluetooth modules in default.pa config file, leading to failure
+to use your bluetooth device (see
+https://github.com/EHfive/pulseaudio-modules-bt/issues/33).
+Please ensure you have this lines present in your /etc/pulse/default.pa
+file:
+
+.ifexists module-bluetooth-policy.so
+load-module module-bluetooth-policy
+.endif
+
+.ifexists module-bluetooth-discover.so
+load-module module-bluetooth-discover
+.endif
+"
+
+src_install() {
+ cmake-utils_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}