summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-03-11 22:24:17 +0100
committerIan Delaney <idella4@gentoo.org>2016-03-19 19:19:20 +0800
commit2970ef097b92c747ea2b95dfdcca8f6ef1a743e9 (patch)
treed5fe0f63d93aeee20253afcb55e1cbd798579c2d /net-analyzer/ipsumdump/ipsumdump-1.85.ebuild
parentLicense: new license: the-Click-license for ipsumdump (diff)
downloadgentoo-2970ef097b92c747ea2b95dfdcca8f6ef1a743e9.tar.gz
gentoo-2970ef097b92c747ea2b95dfdcca8f6ef1a743e9.tar.bz2
gentoo-2970ef097b92c747ea2b95dfdcca8f6ef1a743e9.zip
net-analyzer/ipsumdump: initial ebuild, version 1.85
ipsumdump is actually a small collection of three tiny utilities to process libpcap output. It's necessary for net-analyzer/bro, a network security scanner. Package-Manager: portage-2.2.27 RepoMan-Options: --ignore-arches Closes: https://github.com/gentoo/gentoo/pull/1069
Diffstat (limited to 'net-analyzer/ipsumdump/ipsumdump-1.85.ebuild')
-rw-r--r--net-analyzer/ipsumdump/ipsumdump-1.85.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-analyzer/ipsumdump/ipsumdump-1.85.ebuild b/net-analyzer/ipsumdump/ipsumdump-1.85.ebuild
new file mode 100644
index 000000000000..6155368917a3
--- /dev/null
+++ b/net-analyzer/ipsumdump/ipsumdump-1.85.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Simple TCP/IP Dump summarizer/analyzer"
+HOMEPAGE="http://read.seas.harvard.edu/~kohler/ipsumdump/"
+SRC_URI="http://read.seas.harvard.edu/~kohler/ipsumdump/${P}.tar.gz"
+
+LICENSE="the-Click-license"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ipv6 +nanotimestamp"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-libs/expat
+ sys-apps/texinfo"
+
+src_configure() {
+ econf $(use_enable ipv6 ip6) \
+ $(use_enable nanotimestamp)
+}