summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-12-20 07:20:31 -0500
committerMichael Orlitzky <mjo@gentoo.org>2019-12-20 18:51:28 -0500
commit37d33e80d0a18481d6fa5e5b3bb3c898131fe7f6 (patch)
tree796541eab3d80a9f6c6047b72b7e46477594da18 /net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild
parentdev-util/pkgcheck: version bump to 0.7.2 (diff)
downloadgentoo-37d33e80d0a18481d6fa5e5b3bb3c898131fe7f6.tar.gz
gentoo-37d33e80d0a18481d6fa5e5b3bb3c898131fe7f6.tar.bz2
gentoo-37d33e80d0a18481d6fa5e5b3bb3c898131fe7f6.zip
net-analyzer/nagios-check_multiple: new nagios plugin to run multiple checks.
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild')
-rw-r--r--net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild b/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild
new file mode 100644
index 000000000000..54b6ca191727
--- /dev/null
+++ b/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PN="check_multiple"
+DESCRIPTION="A Nagios plugin to execute multiple checks in parallel"
+HOMEPAGE="https://github.com/clarkbox/${MY_PN}"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest -v lib/check_multiple/check_multiple.py \
+ || die "test suite failed"
+}