summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-22 23:09:29 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-23 01:50:59 +0200
commitcd5b4642f21e524e21d1b1c6aa8b034f9113d7cb (patch)
tree6fe04c36e166525a12e3c1f8a7fe517e413ecbb4 /net-analyzer/packit/packit-1.6.1.ebuild
parentnet-analyzer/sniffit: Version 0.4.0 (diff)
downloadgentoo-cd5b4642f21e524e21d1b1c6aa8b034f9113d7cb.tar.gz
gentoo-cd5b4642f21e524e21d1b1c6aa8b034f9113d7cb.tar.bz2
gentoo-cd5b4642f21e524e21d1b1c6aa8b034f9113d7cb.zip
net-analyzer/packit: Version 1.6.1
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/packit/packit-1.6.1.ebuild')
-rw-r--r--net-analyzer/packit/packit-1.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/packit/packit-1.6.1.ebuild b/net-analyzer/packit/packit-1.6.1.ebuild
new file mode 100644
index 000000000000..cd4fb1dfab52
--- /dev/null
+++ b/net-analyzer/packit/packit-1.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="network packet generator and capture tool"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/packit"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-noopt.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc docs/*
+}