summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/packit/packit-1.6.1.ebuild')
-rw-r--r--net-analyzer/packit/packit-1.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/packit/packit-1.6.1.ebuild b/net-analyzer/packit/packit-1.6.1.ebuild
new file mode 100644
index 000000000000..cd4fb1dfab52
--- /dev/null
+++ b/net-analyzer/packit/packit-1.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="network packet generator and capture tool"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/packit"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-noopt.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc docs/*
+}