summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-27 07:38:50 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-27 07:39:49 +0200
commitf1a368ed1ede5a27f90c4e86d4fa54ccacf993bf (patch)
treecc06c2e69800168991360daf69d40782a078bb38 /net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild
parentdev-ruby/yajl-ruby: add 1.4.3 (diff)
downloadgentoo-f1a368ed1ede5a27f90c4e86d4fa54ccacf993bf.tar.gz
gentoo-f1a368ed1ede5a27f90c4e86d4fa54ccacf993bf.tar.bz2
gentoo-f1a368ed1ede5a27f90c4e86d4fa54ccacf993bf.zip
net-analyzer/ssh-audit: initial import of 2.5.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild')
-rw-r--r--net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild b/net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild
new file mode 100644
index 000000000000..4f67c7b42ec0
--- /dev/null
+++ b/net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{8,9,10})
+
+inherit distutils-r1
+
+DESCRIPTION="SSH server auditing (banner, key exchange, encryption, mac, compression, etc)"
+HOMEPAGE="https://github.com/jtesta/ssh-audit"
+SRC_URI="https://github.com/jtesta/ssh-audit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Tests require prospector which is not packaged
+RESTRICT="test"
+
+src_install() {
+ distutils-r1_src_install
+
+ doman ssh-audit.1
+}