summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild')
-rw-r--r--net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild b/net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild
new file mode 100644
index 000000000000..4f67c7b42ec0
--- /dev/null
+++ b/net-analyzer/ssh-audit/ssh-audit-2.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{8,9,10})
+
+inherit distutils-r1
+
+DESCRIPTION="SSH server auditing (banner, key exchange, encryption, mac, compression, etc)"
+HOMEPAGE="https://github.com/jtesta/ssh-audit"
+SRC_URI="https://github.com/jtesta/ssh-audit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Tests require prospector which is not packaged
+RESTRICT="test"
+
+src_install() {
+ distutils-r1_src_install
+
+ doman ssh-audit.1
+}