summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-06-28 14:22:06 -0400
committerMike Gilbert <floppym@gentoo.org>2021-06-29 12:20:29 -0400
commit057c34468b21195fea18bc4b1fe59f0d4a422520 (patch)
tree9521f115a6cf8481b9bfe6ac1535d0fa75820598 /net-analyzer
parentmedia-sound/pulseaudio: migrate to tmpfiles.eclass (diff)
downloadgentoo-057c34468b21195fea18bc4b1fe59f0d4a422520.tar.gz
gentoo-057c34468b21195fea18bc4b1fe59f0d4a422520.tar.bz2
gentoo-057c34468b21195fea18bc4b1fe59f0d4a422520.zip
net-analyzer/zabbix: migrate to tmpfiles.eclass
The systemd_newtmpfilesd function is deprecated. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.10-r1.ebuild10
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.11-r1.ebuild10
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild10
-rw-r--r--net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild10
-rw-r--r--net-analyzer/zabbix/zabbix-5.4.0-r1.ebuild10
-rw-r--r--net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild10
6 files changed, 30 insertions, 30 deletions
diff --git a/net-analyzer/zabbix/zabbix-5.0.10-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.10-r1.ebuild
index 87d5506841fe..33057925ecd0 100644
--- a/net-analyzer/zabbix/zabbix-5.0.10-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.10-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit webapp java-pkg-opt-2 systemd toolchain-funcs go-module user-info
+inherit webapp java-pkg-opt-2 systemd tmpfiles toolchain-funcs go-module user-info
EGO_SUM=(
"github.com/BurntSushi/locker v0.0.0-20171006230638-a6e239ea1c69 h1:+tu3HOoMXB7RXEINRVIpxJCT+KdYiI7LAEAUrOw3dIU="
"github.com/BurntSushi/locker v0.0.0-20171006230638-a6e239ea1c69/go.mod h1:L1AbZdiDllfyYH5l5OkAaZtk7VkWe89bPJFmnDBNHxg="
@@ -421,7 +421,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-server.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+ newtmpfiles "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
fi
if use proxy; then
@@ -438,7 +438,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-proxy.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+ newtmpfiles "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
fi
if use agent; then
@@ -455,7 +455,7 @@ src_install() {
src/zabbix_get/zabbix_get
systemd_dounit "${FILESDIR}"/zabbix-agentd.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
fi
if use agent2; then
@@ -469,7 +469,7 @@ src_install() {
dosbin src/go/bin/zabbix_agent2
systemd_dounit "${FILESDIR}"/zabbix-agent2.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
fi
fowners root:zabbix /etc/zabbix
diff --git a/net-analyzer/zabbix/zabbix-5.0.11-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.11-r1.ebuild
index 87d5506841fe..33057925ecd0 100644
--- a/net-analyzer/zabbix/zabbix-5.0.11-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.11-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit webapp java-pkg-opt-2 systemd toolchain-funcs go-module user-info
+inherit webapp java-pkg-opt-2 systemd tmpfiles toolchain-funcs go-module user-info
EGO_SUM=(
"github.com/BurntSushi/locker v0.0.0-20171006230638-a6e239ea1c69 h1:+tu3HOoMXB7RXEINRVIpxJCT+KdYiI7LAEAUrOw3dIU="
"github.com/BurntSushi/locker v0.0.0-20171006230638-a6e239ea1c69/go.mod h1:L1AbZdiDllfyYH5l5OkAaZtk7VkWe89bPJFmnDBNHxg="
@@ -421,7 +421,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-server.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+ newtmpfiles "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
fi
if use proxy; then
@@ -438,7 +438,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-proxy.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+ newtmpfiles "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
fi
if use agent; then
@@ -455,7 +455,7 @@ src_install() {
src/zabbix_get/zabbix_get
systemd_dounit "${FILESDIR}"/zabbix-agentd.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
fi
if use agent2; then
@@ -469,7 +469,7 @@ src_install() {
dosbin src/go/bin/zabbix_agent2
systemd_dounit "${FILESDIR}"/zabbix-agent2.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
fi
fowners root:zabbix /etc/zabbix
diff --git a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
index 40d10b23dee7..7a329ff5b8b6 100644
--- a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit webapp java-pkg-opt-2 systemd toolchain-funcs go-module user-info
+inherit webapp java-pkg-opt-2 systemd tmpfiles toolchain-funcs go-module user-info
EGO_SUM=(
"github.com/BurntSushi/toml v0.3.1/go.mod h1:xHWCNGjB5oqiDr8zfno3MHue2Ht5sIBksp03qcyfWMU="
"github.com/cockroachdb/apd v1.1.0 h1:3LFP3629v+1aKXU5Q37mxmRxX/pIu1nijXydLShEq5I="
@@ -419,7 +419,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-server.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+ newtmpfiles "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
fi
if use proxy; then
@@ -436,7 +436,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-proxy.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+ newtmpfiles "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
fi
if use agent; then
@@ -453,7 +453,7 @@ src_install() {
src/zabbix_get/zabbix_get
systemd_dounit "${FILESDIR}"/zabbix-agentd.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
fi
if use agent2; then
@@ -467,7 +467,7 @@ src_install() {
dosbin src/go/bin/zabbix_agent2
systemd_dounit "${FILESDIR}"/zabbix-agent2.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
fi
fowners root:zabbix /etc/zabbix
diff --git a/net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild b/net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild
index 7b7445ca6d86..0abc5c330633 100644
--- a/net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.2.6-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit webapp java-pkg-opt-2 systemd toolchain-funcs go-module user-info
+inherit webapp java-pkg-opt-2 systemd tmpfiles toolchain-funcs go-module user-info
# content of src/go/go.sum
EGO_SUM=(
"github.com/BurntSushi/locker v0.0.0-20171006230638-a6e239ea1c69 h1:+tu3HOoMXB7RXEINRVIpxJCT+KdYiI7LAEAUrOw3dIU="
@@ -428,7 +428,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-server.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+ newtmpfiles "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
fi
if use proxy; then
@@ -445,7 +445,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-proxy.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+ newtmpfiles "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
fi
if use agent; then
@@ -462,7 +462,7 @@ src_install() {
src/zabbix_get/zabbix_get
systemd_dounit "${FILESDIR}"/zabbix-agentd.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
fi
if use agent2; then
insinto /etc/zabbix
@@ -475,7 +475,7 @@ src_install() {
dosbin src/go/bin/zabbix_agent2
systemd_dounit "${FILESDIR}"/zabbix-agent2.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
fi
fowners root:zabbix /etc/zabbix
diff --git a/net-analyzer/zabbix/zabbix-5.4.0-r1.ebuild b/net-analyzer/zabbix/zabbix-5.4.0-r1.ebuild
index 71c7af9479ba..359d8dd9cdd5 100644
--- a/net-analyzer/zabbix/zabbix-5.4.0-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.4.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit webapp java-pkg-opt-2 systemd toolchain-funcs go-module user-info
+inherit webapp java-pkg-opt-2 systemd tmpfiles toolchain-funcs go-module user-info
# content of src/go/go.sum
EGO_SUM=(
"github.com/BurntSushi/locker v0.0.0-20171006230638-a6e239ea1c69 h1:+tu3HOoMXB7RXEINRVIpxJCT+KdYiI7LAEAUrOw3dIU="
@@ -444,7 +444,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-server.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+ newtmpfiles "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
fi
if use proxy; then
@@ -461,7 +461,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-proxy.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+ newtmpfiles "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
fi
if use agent; then
@@ -478,7 +478,7 @@ src_install() {
src/zabbix_get/zabbix_get
systemd_dounit "${FILESDIR}"/zabbix-agentd.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
fi
if use agent2; then
insinto /etc/zabbix
@@ -491,7 +491,7 @@ src_install() {
dosbin src/go/bin/zabbix_agent2
systemd_dounit "${FILESDIR}"/zabbix-agent2.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
fi
fowners root:zabbix /etc/zabbix
diff --git a/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild b/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
index 71c7af9479ba..359d8dd9cdd5 100644
--- a/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit webapp java-pkg-opt-2 systemd toolchain-funcs go-module user-info
+inherit webapp java-pkg-opt-2 systemd tmpfiles toolchain-funcs go-module user-info
# content of src/go/go.sum
EGO_SUM=(
"github.com/BurntSushi/locker v0.0.0-20171006230638-a6e239ea1c69 h1:+tu3HOoMXB7RXEINRVIpxJCT+KdYiI7LAEAUrOw3dIU="
@@ -444,7 +444,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-server.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+ newtmpfiles "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
fi
if use proxy; then
@@ -461,7 +461,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-proxy.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+ newtmpfiles "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
fi
if use agent; then
@@ -478,7 +478,7 @@ src_install() {
src/zabbix_get/zabbix_get
systemd_dounit "${FILESDIR}"/zabbix-agentd.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
fi
if use agent2; then
insinto /etc/zabbix
@@ -491,7 +491,7 @@ src_install() {
dosbin src/go/bin/zabbix_agent2
systemd_dounit "${FILESDIR}"/zabbix-agent2.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agent2.tmpfiles zabbix-agent2.conf
fi
fowners root:zabbix /etc/zabbix