summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-07-11 16:30:42 +0200
committerSam James <sam@gentoo.org>2021-07-16 02:33:22 +0100
commit9edbadd7a1a92eebb5a46ce0b89d614e114ac64e (patch)
tree786e651e64ea1057754571aac7bceac936b0b60b /net-analyzer
parentnet-misc/sipcalc: remove old (diff)
downloadgentoo-9edbadd7a1a92eebb5a46ce0b89d614e114ac64e.tar.gz
gentoo-9edbadd7a1a92eebb5a46ce0b89d614e114ac64e.tar.bz2
gentoo-9edbadd7a1a92eebb5a46ce0b89d614e114ac64e.zip
net-analyzer/iplog: EAPI8 revbump, ebuild improvements
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/21603 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/iplog/iplog-2.2.3-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/iplog/iplog-2.2.3-r3.ebuild b/net-analyzer/iplog/iplog-2.2.3-r3.ebuild
new file mode 100644
index 000000000000..09cfb969491a
--- /dev/null
+++ b/net-analyzer/iplog/iplog-2.2.3-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="TCP/IP traffic logger"
+HOMEPAGE="http://ojnk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 FDL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PV}-DLT_LINUX_SSL.patch )
+
+DOCS=( AUTHORS NEWS README TODO example-iplog.conf )
+
+src_compile() {
+ append-cppflags -D_REENTRANT
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" all
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/iplog.rc6 iplog
+}