summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-07-29 18:56:07 +0000
committerMichał Górny <mgorny@gentoo.org>2020-08-27 11:20:15 +0200
commitefe78ca9cbec45cef600ecac4bbfa15273ae266a (patch)
tree395c53063e5ca79046df2a316e3787a82f00de89 /net-analyzer
parentnet-analyzer/linkchecker: sync live ebuild (diff)
downloadgentoo-efe78ca9cbec45cef600ecac4bbfa15273ae266a.tar.gz
gentoo-efe78ca9cbec45cef600ecac4bbfa15273ae266a.tar.bz2
gentoo-efe78ca9cbec45cef600ecac4bbfa15273ae266a.zip
net-analyzer/linkchecker: add snapshot with python3 support
Bug: https://bugs.gentoo.org/712958 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/Manifest1
-rw-r--r--net-analyzer/linkchecker/linkchecker-10.0.0_pre20200729.ebuild60
-rw-r--r--net-analyzer/linkchecker/linkchecker-9999.ebuild2
3 files changed, 62 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/Manifest b/net-analyzer/linkchecker/Manifest
index b02b528ba45e..bf2898005f76 100644
--- a/net-analyzer/linkchecker/Manifest
+++ b/net-analyzer/linkchecker/Manifest
@@ -1 +1,2 @@
+DIST linkchecker-10.0.0_pre20200729.tar.gz 401694 BLAKE2B f1a0918c30b292e569fd3168eee152e63ba7266f0ef848a55601e0205d8b0521cb653db77c8dc7b5d1140b493c95e50d76acba44e961586159f2b691e6898353 SHA512 35c49ca5de06688667e39f4eb0d8a048e565fe460a4aff125a484e3966c62cbea95fd95154cb2b544c0f4987f66012793726cf890d604321ed83970654a318f6
DIST linkchecker-9.4.0.tar.gz 489909 BLAKE2B 1c9d9af96778f9d2b542a078ba9da8751d6f7bc170809d5eefef6e8e2d5587e969f1cba3d6ae116b6de981949dd638b0d78fc416ce5055b3156da308b5a95d67 SHA512 3423f710a46d921c4387ffcfe1a8632cb889bcfdb4d56cbabcae87ca41547221e854546efd6e440e798ea85531c34a35f3ab779cd6bc2b6e63095015ad0537ba
diff --git a/net-analyzer/linkchecker/linkchecker-10.0.0_pre20200729.ebuild b/net-analyzer/linkchecker/linkchecker-10.0.0_pre20200729.ebuild
new file mode 100644
index 000000000000..0eecf32e4cd4
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-10.0.0_pre20200729.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="https://github.com/linkcheck/linkchecker"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/linkcheck/linkchecker.git"
+ inherit git-r3
+else
+ GIT_COMMIT="a977e4d7129450ba9fda8389724c80c1bde66883"
+ SRC_URI="https://github.com/linkchecker/linkchecker/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="sqlite"
+# requires py2 only libs
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-9.3-bash-completion.patch"
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=(
+ doc/changelog.txt
+ doc/upgrading.txt
+ )
+ distutils-r1_python_install_all
+
+ newbashcomp config/linkchecker-completion ${PN}
+}
+
+pkg_postinst() {
+ optfeature "bash-completion support" dev-python/argcomplete[${PYTHON_USEDEP}]
+ optfeature "Virus scanning" app-antivirus/clamav
+ optfeature "Geo IP support" dev-python/geoip-python[${PYTHON_USEDEP}]
+ optfeature "GNOME proxy settings support" dev-python/pygobject[${PYTHON_USEDEP}]
+}
diff --git a/net-analyzer/linkchecker/linkchecker-9999.ebuild b/net-analyzer/linkchecker/linkchecker-9999.ebuild
index 96c44d5d7cb4..b1b371fb4989 100644
--- a/net-analyzer/linkchecker/linkchecker-9999.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="sqlite?"
inherit bash-completion-r1 distutils-r1 eutils