summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-08-27 10:32:17 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-08-29 13:35:08 +0300
commit382ebcd415df01ea5262f1286f85faeafd85c4e4 (patch)
tree4c702df1e351a182cd78c98d1d94797f4567b0c0 /net-im/profanity/profanity-0.14.0-r1.ebuild
parentnet-im/profanity: add use flag to add support of python plugins (diff)
downloadgentoo-382ebcd415df01ea5262f1286f85faeafd85c4e4.tar.gz
gentoo-382ebcd415df01ea5262f1286f85faeafd85c4e4.tar.bz2
gentoo-382ebcd415df01ea5262f1286f85faeafd85c4e4.zip
net-im/profanity: add two upstream patches
profanity-0.14.0-ox-carbons.patch: Fix wrong display of ox carbons. profanity-0.14.0-xscreensaver.patch: Fix spamming of logs when no X is running. Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/32471 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im/profanity/profanity-0.14.0-r1.ebuild')
-rw-r--r--net-im/profanity/profanity-0.14.0-r1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-im/profanity/profanity-0.14.0-r1.ebuild b/net-im/profanity/profanity-0.14.0-r1.ebuild
index 537409d27d05..f5c591413f3e 100644
--- a/net-im/profanity/profanity-0.14.0-r1.ebuild
+++ b/net-im/profanity/profanity-0.14.0-r1.ebuild
@@ -3,12 +3,18 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit python-single-r1
DESCRIPTION="A console based XMPP client inspired by Irssi"
HOMEPAGE="https://profanity-im.github.io"
-SRC_URI="https://github.com/profanity-im/profanity/releases/download/${PV}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/profanity-im/profanity/releases/download/${PV}/${P}.tar.gz
+ https://github.com/profanity-im/profanity/commit/122434a.patch
+ -> ${PN}-0.14.0-ox-carbons.patch
+ https://github.com/profanity-im/profanity/commit/2ed6211c.patch
+ -> ${PN}-0.14.0-xscreensaver.patch
+"
LICENSE="GPL-3"
SLOT="0"
@@ -55,6 +61,11 @@ DEPEND="
)
"
+PATCHES=(
+ "${DISTDIR}/${PN}-0.14.0-ox-carbons.patch"
+ "${DISTDIR}/${PN}-0.14.0-xscreensaver.patch"
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}