summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-01-08 20:42:18 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-01-08 20:42:31 -0500
commit37bd823f08a8c8f4d38d0c45201723ffec407b23 (patch)
tree457f0abd03929cd7333ef291e95170af43996af2 /net-libs/stem/stem-1.7.1.ebuild
parentwww-client/epiphany: x86 stable (bug #674870) (diff)
downloadgentoo-37bd823f08a8c8f4d38d0c45201723ffec407b23.tar.gz
gentoo-37bd823f08a8c8f4d38d0c45201723ffec407b23.tar.bz2
gentoo-37bd823f08a8c8f4d38d0c45201723ffec407b23.zip
net-libs/stem: version bump to 1.7.1
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs/stem/stem-1.7.1.ebuild')
-rw-r--r--net-libs/stem/stem-1.7.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/stem/stem-1.7.1.ebuild b/net-libs/stem/stem-1.7.1.ebuild
new file mode 100644
index 000000000000..9a38c64d97dd
--- /dev/null
+++ b/net-libs/stem/stem-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6,3_7})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-vpn/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-vpn/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_parsing_with_example/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_parsing_with_unknown_options/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_saving_manual/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_sdist_matches_git/a \
+ \ \ \ \ return" test/integ/installation.py || die
+ sed -i -e "/test_connections_by_ss/a \
+ \ \ \ \ return" test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}