summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-07-08 16:43:54 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-08 16:46:29 +0200
commit6f331c64b66482d619980b34389798d33ea04f7d (patch)
tree3e1a96cde824f92063c9d1453676a45091a13ed4 /net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild
parentnet-misc/dhcdrop: revision bump (diff)
downloadgentoo-6f331c64b66482d619980b34389798d33ea04f7d.tar.gz
gentoo-6f331c64b66482d619980b34389798d33ea04f7d.tar.bz2
gentoo-6f331c64b66482d619980b34389798d33ea04f7d.zip
net-libs/xrootd-ceph: bump to 5.0.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild')
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild
new file mode 100644
index 000000000000..f38a421f4865
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-5.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=net-libs/xrootd-5.0.0
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-util/cppunit )"
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrdCeph.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdCephTests\.so"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ # As of 5.0.0 the default plug-in version is still 4.
+ -DPLUGIN_VERSION=$(ver_cut 1)
+ )
+ cmake_src_configure
+}