summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-21 13:03:48 -0300
committerMatt Turner <mattst88@gentoo.org>2022-11-23 11:43:37 -0500
commit4a55ae024d2049169699ea13406fe5901ab22bc5 (patch)
tree13e713128e44c1c822a7e6cc13d6be62f6d0d66e /net-libs
parentnet-libs/gupnp: Version bump to 1.6.2 (diff)
downloadgentoo-4a55ae024d2049169699ea13406fe5901ab22bc5.tar.gz
gentoo-4a55ae024d2049169699ea13406fe5901ab22bc5.tar.bz2
gentoo-4a55ae024d2049169699ea13406fe5901ab22bc5.zip
net-libs/gssdp: Version bump to 1.6.2
Closes: https://github.com/gentoo/gentoo/pull/28367 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gssdp/Manifest1
-rw-r--r--net-libs/gssdp/gssdp-1.6.2.ebuild69
-rw-r--r--net-libs/gssdp/metadata.xml3
3 files changed, 73 insertions, 0 deletions
diff --git a/net-libs/gssdp/Manifest b/net-libs/gssdp/Manifest
index 7293de73ae5d..ddf035d952e8 100644
--- a/net-libs/gssdp/Manifest
+++ b/net-libs/gssdp/Manifest
@@ -1,3 +1,4 @@
DIST gssdp-1.4.0.1.tar.xz 1229264 BLAKE2B b94e46c79ad0615f976bad4b8efe9dbcaa27105b3189ee23ff349002d175ff83b0a9507846a23f0d8b5ed1e98381658f863a77bec6beff83933ebae5458a6b0e SHA512 c2132b27f49071941be1ad9bd1e642b8b82341aac7e10b87d8a9a0ed3d88759ab6730a4a05ddb904af5e0799602c470b9e83a987c72ec3c1444b7aaef0e36ad8
DIST gssdp-1.6.0.tar.xz 1232568 BLAKE2B f9c76a867d77f19dbb5f3c8e58177884ebe32a822793dcfdbc12c7a3e80aea5eb56e3212fbf0949535bbf5d1b4eb51a0696c3fbf8c50fce33c9616d94b97d28a SHA512 ad631a869059be06521f093f578228a1c51c7df1eb1be0cf1d2e09ed769c639119565f5af4e252deb336a7edb8d500e6d391b72bb0fd870abd2485874f9f1d8f
DIST gssdp-1.6.1.tar.xz 2080496 BLAKE2B 29453e746daed62fe651ba726a3bc7ae2d64bdaf08340ecd5647eaf535dbd2960da56e46b36f87bb73054403514b88787f25e4e9e014506864f35e88b579d0d1 SHA512 4569a74252efb597cddd774a9648f899dc784837a164595f7c8d851892a9fbcee7bbf926c136be5cbd72314fabaae0cdbffba941393f62d2d967e3be4146c5ca
+DIST gssdp-1.6.2.tar.xz 2081568 BLAKE2B d11ea1f5d5980c6380dd3a072fc6d8a33894e4cd5c5978862b1fe99ecaed679cee2ecd37a80aa374bb255c8771520501243f334092261465e641a772561a15e0 SHA512 501e2839022b3c175b17b27b8b1134021631726eca331ab7b64f895be770f5b754c50cdfaa03e833a3d95180471cda6a87b17ffeff661f3de228a5b70a2a6cbb
diff --git a/net-libs/gssdp/gssdp-1.6.2.ebuild b/net-libs/gssdp/gssdp-1.6.2.ebuild
new file mode 100644
index 000000000000..2a6c944d5900
--- /dev/null
+++ b/net-libs/gssdp/gssdp-1.6.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib vala xdg
+
+DESCRIPTION="GObject-based API for handling resource discovery and announcement over SSDP"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP https://gitlab.gnome.org/GNOME/gssdp"
+
+LICENSE="LGPL-2+"
+SLOT="1.6/1.6-0" # <API version>-<soname>
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk gtk-doc +introspection man +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+
+# has file collision with Slot 0 (/usr/bin/gssdp-device-sniffer), so we remove that from this build
+# and depend on the other slot that has the file as well
+RDEPEND="
+ >=dev-libs/glib-2.70:2[${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.99.0:3.0[${MULTILIB_USEDEP},introspection?]
+ gtk? ( gui-libs/gtk:4 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ man? ( virtual/pandoc )
+ >=net-libs/gssdp-1.4:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? (
+ >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ virtual/pkgconfig
+ vala? (
+ $(vala_depend)
+ net-libs/libsoup:3.0[vala]
+ )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ $(meson_native_use_bool gtk sniffer)
+ $(meson_native_use_bool introspection)
+ $(meson_native_use_bool man manpages)
+ $(meson_native_use_bool vala vapi)
+ -Dexamples=false
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ if use gtk-doc ; then
+ mkdir "${ED}"/usr/share/gtk-doc || die
+ mv "${ED}"/usr/share/{doc,gtk-doc}/gssdp-1.6 || die
+ fi
+ rm "${ED}"/usr/bin/gssdp-device-sniffer || die # because of file collision with slot 0
+}
diff --git a/net-libs/gssdp/metadata.xml b/net-libs/gssdp/metadata.xml
index 7cf1d415ce27..1ae928e5f9fe 100644
--- a/net-libs/gssdp/metadata.xml
+++ b/net-libs/gssdp/metadata.xml
@@ -5,6 +5,9 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+ <use>
+ <flag name="man">Generate man page for tools</flag>
+ </use>
<upstream>
<remote-id type="gnome-gitlab">GNOME/gssdp</remote-id>
</upstream>