summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-02 09:49:27 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-02 10:43:18 +0200
commitaf73ad4881c33899d4a796aec673d4021e697e22 (patch)
treed8e194e3c608c7287ab9b4be01ba133c6eab420b /net-misc/autoupnp/autoupnp-0.4.7.ebuild
parentmedia-sound/mumble: Bump to version 1.2.10 (bug #552092) (diff)
downloadgentoo-af73ad4881c33899d4a796aec673d4021e697e22.tar.gz
gentoo-af73ad4881c33899d4a796aec673d4021e697e22.tar.bz2
gentoo-af73ad4881c33899d4a796aec673d4021e697e22.zip
net-misc/autoupnp: Version bump with miniupnpc compat fix
Package-Manager: portage-2.2.22
Diffstat (limited to 'net-misc/autoupnp/autoupnp-0.4.7.ebuild')
-rw-r--r--net-misc/autoupnp/autoupnp-0.4.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/autoupnp/autoupnp-0.4.7.ebuild b/net-misc/autoupnp/autoupnp-0.4.7.ebuild
new file mode 100644
index 000000000000..b7f066586cb7
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.4.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=(
+ $(use_with libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}