summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-03-01 00:15:57 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-03-15 09:45:29 +0200
commit75ed4c75531c1e12dc8bc8c774d645ea2d032201 (patch)
tree816907e33fdfc6295f1cf1869b86ee7a84839ae7 /net-misc/connect/connect-1.105.ebuild
parentdev-python/twisted: Keyword 21.2.0 ppc64, #773451 (diff)
downloadgentoo-75ed4c75531c1e12dc8bc8c774d645ea2d032201.tar.gz
gentoo-75ed4c75531c1e12dc8bc8c774d645ea2d032201.tar.bz2
gentoo-75ed4c75531c1e12dc8bc8c774d645ea2d032201.zip
net-misc/connect: update to 1.105
Update ebuild to EAPI 7, updated license to GPL-2+, updated HOMEPAGE and SRC_URI (#739802), documentation, cleaning up. Closes: https://bugs.gentoo.org/739802 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19715 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/connect/connect-1.105.ebuild')
-rw-r--r--net-misc/connect/connect-1.105.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/connect/connect-1.105.ebuild b/net-misc/connect/connect-1.105.ebuild
new file mode 100644
index 000000000000..b1c4c97f5b62
--- /dev/null
+++ b/net-misc/connect/connect-1.105.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="SSH Proxy Command"
+HOMEPAGE="https://github.com/gotoh/ssh-connect"
+SRC_URI="https://github.com/gotoh/ssh-connect/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+S="${WORKDIR}/ssh-connect-${PV}"
+
+src_prepare() {
+ default
+ sed -i -e "s/CFLAGS=/CFLAGS+=/g" -e "s/CC=/CC?=/g" Makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc doc/manual.txt
+}