summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-13 23:30:16 +0200
committerSam James <sam@gentoo.org>2021-05-14 01:24:36 +0100
commit9cc6e5ae81288c4a3a2c68cdb74368e0378b21a3 (patch)
tree317bc83ca252d8a5851e957ec1c4f291b794a46e /net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
parentmail-client/neomutt: Do not call `cc` (diff)
downloadgentoo-9cc6e5ae81288c4a3a2c68cdb74368e0378b21a3.tar.gz
gentoo-9cc6e5ae81288c4a3a2c68cdb74368e0378b21a3.tar.bz2
gentoo-9cc6e5ae81288c4a3a2c68cdb74368e0378b21a3.zip
net-misc/kea: Fix compiling with GCC 11
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/20798 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch')
-rw-r--r--net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch b/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
new file mode 100644
index 000000000000..867561f2e7e5
--- /dev/null
+++ b/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
@@ -0,0 +1,50 @@
+--- a/m4macros/ax_cpp11.m4
++++ b/m4macros/ax_cpp11.m4
+@@ -182,6 +182,7 @@
+ AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [#include <thread>
++ #include <memory>
+ std::shared_ptr<std::thread> th;],
+ [th.reset(new std::thread([[]]() { return; }));
+ th->join();])],
+--- a/src/bin/perfdhcp/Makefile.am
++++ b/src/bin/perfdhcp/Makefile.am
+@@ -3,7 +3,6 @@
+ AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
+ AM_CPPFLAGS += -I$(top_srcdir)/src/bin -I$(top_builddir)/src/bin
+ AM_CPPFLAGS += $(BOOST_INCLUDES)
+-AM_CPPFLAGS += -Werror
+
+ AM_CXXFLAGS = $(KEA_CXXFLAGS)
+
+--- a/src/bin/perfdhcp/tests/Makefile.am
++++ b/src/bin/perfdhcp/tests/Makefile.am
+@@ -4,7 +4,6 @@
+ AM_CPPFLAGS += -I$(srcdir)/.. -I$(builddir)/..
+ AM_CPPFLAGS += -DTEST_DATA_DIR=\"$(abs_srcdir)/testdata\"
+ AM_CPPFLAGS += $(BOOST_INCLUDES)
+-AM_CPPFLAGS += -Werror
+ AM_CXXFLAGS = $(KEA_CXXFLAGS)
+
+ if USE_STATIC_LINK
+--- a/src/lib/database/backend_selector.cc
++++ b/src/lib/database/backend_selector.cc
+@@ -7,6 +7,7 @@
+ #include <database/backend_selector.h>
+ #include <exceptions/exceptions.h>
+ #include <climits>
++#include <limits>
+ #include <sstream>
+
+ using namespace isc::data;
+--- a/src/lib/dhcpsrv/subnet_id.h
++++ b/src/lib/dhcpsrv/subnet_id.h
+@@ -10,6 +10,7 @@
+ #include <exceptions/exceptions.h>
+ #include <stdint.h>
+ #include <typeinfo>
++#include <limits>
+
+ namespace isc {
+ namespace dhcp {