summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-12 05:56:24 +0000
committerSam James <sam@gentoo.org>2023-02-12 06:10:19 +0000
commitb234dd8bbcf255937a8357d10eaa334e68b0bd5f (patch)
treec1d6415b8937da65c1149a0acc3e5a602ac8c872 /net-nds
parentmedia-libs/sdl2-image: add 2.6.3 (diff)
downloadgentoo-b234dd8bbcf255937a8357d10eaa334e68b0bd5f.tar.gz
gentoo-b234dd8bbcf255937a8357d10eaa334e68b0bd5f.tar.bz2
gentoo-b234dd8bbcf255937a8357d10eaa334e68b0bd5f.zip
net-nds/openldap: increase test timeouts
In the past, we've seen segfaults or (IIRC) a sigbus once on timeouts, and the test in question here passes on sparc when running outside of Portage anyway. Let's give it a go. Bug: https://bugs.gentoo.org/894012 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/openldap-2.6.4-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/net-nds/openldap/openldap-2.6.4-r1.ebuild b/net-nds/openldap/openldap-2.6.4-r1.ebuild
index 56617abc986c..51316d05feb1 100644
--- a/net-nds/openldap/openldap-2.6.4-r1.ebuild
+++ b/net-nds/openldap/openldap-2.6.4-r1.ebuild
@@ -642,6 +642,7 @@ multilib_src_compile() {
$(tc-getCC) -shared \
-I"${BUILD_DIR}"/include \
-I../../../include \
+ ${CPPFLAGS} \
${CFLAGS} \
-fPIC \
${LDFLAGS} \
@@ -656,6 +657,13 @@ multilib_src_test() {
cd tests || die
pwd
+ # Increase various test timeouts/delays, bug #894012
+ # We can't just double everything as there's a cumulative effect.
+ export SLEEP0=2 # originally 1
+ export SLEEP1=10 # originally 7
+ export SLEEP2=20 # originally 15
+ export TIMEOUT=16 # originally 8
+
# emake test => runs only lloadd & mdb, in serial; skips ldif,sql,wt,regression
# emake partests => runs ALL of the tests in parallel
# wt/WiredTiger is not supported in Gentoo