summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-06 09:58:54 +0000
committerSam James <sam@gentoo.org>2024-02-06 09:59:57 +0000
commitfdab46d0af0e9a511262b87502c804875217d2e7 (patch)
treec506fedc4a6b036bd3d4e45334b92f65cd457143 /net-proxy/squid/squid-6.6.ebuild
parentsec-keys/openpgp-keys-squid: new package, add 20240206 (diff)
downloadgentoo-fdab46d0af0e9a511262b87502c804875217d2e7.tar.gz
gentoo-fdab46d0af0e9a511262b87502c804875217d2e7.tar.bz2
gentoo-fdab46d0af0e9a511262b87502c804875217d2e7.zip
net-proxy/squid: add verify-sig support
Was originally going to do this with squid-6.7 but that is kind of semi-released: it doesn't have a tag in the git repo and 6.7 has a tarball up and it's signed but I have no idea what key signed it. Unlike 6.6 where it's from the known keyring. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy/squid/squid-6.6.ebuild')
-rw-r--r--net-proxy/squid/squid-6.6.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-proxy/squid/squid-6.6.ebuild b/net-proxy/squid/squid-6.6.ebuild
index 99d72292a7dd..0f87a54910f4 100644
--- a/net-proxy/squid/squid-6.6.ebuild
+++ b/net-proxy/squid/squid-6.6.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit autotools flag-o-matic linux-info pam systemd toolchain-funcs
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/squid.gpg
+inherit autotools flag-o-matic linux-info pam systemd toolchain-funcs verify-sig
DESCRIPTION="Full-featured web proxy cache"
HOMEPAGE="http://www.squid-cache.org/"
@@ -13,7 +14,10 @@ MY_PV_MAJOR=$(ver_cut 1)
#r=-20181117-r0022167
r=
if [[ -z ${r} ]]; then
- SRC_URI="http://static.squid-cache.org/Versions/v${MY_PV_MAJOR}/${P}.tar.xz"
+ SRC_URI="
+ http://static.squid-cache.org/Versions/v${MY_PV_MAJOR}/${P}.tar.xz
+ verify-sig? ( http://static.squid-cache.org/Versions/v${MY_PV_MAJOR}/${P}.tar.xz.asc )
+ "
else
SRC_URI="http://static.squid-cache.org/Versions/v${MY_PV_MAJOR}/${P}${r}.tar.bz2"
S="${S}${r}"
@@ -72,6 +76,7 @@ BDEPEND="
dev-lang/perl
ecap? ( virtual/pkgconfig )
test? ( dev-util/cppunit )
+ verify-sig? ( sec-keys/openpgp-keys-squid )
"
PATCHES=(