summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-27 02:24:35 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-27 02:48:48 +0000
commit5000ff1a971f78384d5fd03a1d529d6d1ac3db98 (patch)
tree5d578dd15c32fd4734ebb1023230009adee8d335 /sci-astronomy/erfa/erfa-1.4.0.ebuild
parentdev-python/wcsaxes: added python-3.6, and matplotlib environment to avoid imp... (diff)
downloadgentoo-5000ff1a971f78384d5fd03a1d529d6d1ac3db98.tar.gz
gentoo-5000ff1a971f78384d5fd03a1d529d6d1ac3db98.tar.bz2
gentoo-5000ff1a971f78384d5fd03a1d529d6d1ac3db98.zip
sci-astronomy/erfa: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-astronomy/erfa/erfa-1.4.0.ebuild')
-rw-r--r--sci-astronomy/erfa/erfa-1.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-astronomy/erfa/erfa-1.4.0.ebuild b/sci-astronomy/erfa/erfa-1.4.0.ebuild
new file mode 100644
index 000000000000..6a721cbc58f4
--- /dev/null
+++ b/sci-astronomy/erfa/erfa-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Essential Routines for Fundamental Astronomy"
+HOMEPAGE="https://github.com/liberfa/erfa"
+SRC_URI="https://github.com/liberfa/erfa/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}