summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-03 00:20:26 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-03 22:21:00 +0200
commit6e813f13ba23ea1b7adc4b635b4d9508d0a9954c (patch)
treeef4b117bf0f526d48f43f0b15e7b12a1b1443fc9 /sci-biology/phred/files
parentnet-misc/remmina: warn about encrypted VNC deps. (diff)
downloadgentoo-6e813f13ba23ea1b7adc4b635b4d9508d0a9954c.tar.gz
gentoo-6e813f13ba23ea1b7adc4b635b4d9508d0a9954c.tar.bz2
gentoo-6e813f13ba23ea1b7adc4b635b4d9508d0a9954c.zip
sci-biology/phred: Revbump to EAPI=6
Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-biology/phred/files')
-rw-r--r--sci-biology/phred/files/phred-071220-fix-build-system.patch82
-rw-r--r--sci-biology/phred/files/phred-071220-fix-qa.patch36
2 files changed, 118 insertions, 0 deletions
diff --git a/sci-biology/phred/files/phred-071220-fix-build-system.patch b/sci-biology/phred/files/phred-071220-fix-build-system.patch
new file mode 100644
index 000000000000..997f39941a07
--- /dev/null
+++ b/sci-biology/phred/files/phred-071220-fix-build-system.patch
@@ -0,0 +1,82 @@
+* Fix build system to honour CC, CFLAGS, CPPFLAGS and LDFLAGS
+* Specify a default target, in order to keep the ebuild slim
+
+--- a/Makefile
++++ b/Makefile
+@@ -12,9 +12,9 @@
+
+ # UNIX specific definitions (default)
+ #
+-CC= cc
+-CFLAGS= -O -DANSI_C $(LXFLAGS)
+-CLIB= -lm
++CC ?= cc
++CPPFLAGS += -DANSI_C $(LXFLAGS)
++LIBS += -lm
+
+ # Windows 'nmake' specific definitions
+ #
+@@ -133,9 +133,6 @@
+ $(objdir)writeSDF.o \
+ $(objdir)writeSeq.o
+
+-SRCS = $(OBJS:.o=.c)
+-WOBJ = $(OBJS:.o=.obj)
+-
+ INCS = \
+ $(incdir)chromatData.h \
+ $(incdir)freeChromatData.h \
+@@ -179,48 +176,18 @@
+ # UNIX make specific phred target
+ # note: a horizontal tab character must precede `$(CC)'
+ #
+-phred: $(OBJS)
+- $(CC) $(CFLAGS) -o phred $(OBJS) $(CLIB)
+
+
+-# Windows nmake specific phred target
+-#
+-forwindows: $(WOBJ)
+- $(CC) $(CFLAGS) /Fephred $(WOBJ)
+-# $(CC) $(CFLAGS) /Fedaev daev.c
++.PHONY: all
++all: phred daev
+
+
+-# test CC: refuse to compile if
+-#
+-# o SunOS
+-#
+-# AND
+-#
+-# o using /usr/ucb/cc compiler
+-#
+-# NOTE: this compiler causes problems: see PHRED.DOC
+-#
+-test_cc:
+- @if [ `uname` = SunOS ] ; \
+- then \
+- if [ `which $(CC)` = "/usr/ucb/cc" ] ; \
+- then \
+- echo ""; \
+- echo "============================================================"; \
+- echo "| |"; \
+- echo "| This SUN C compiler produces a bad phred executable. |"; \
+- echo "| |"; \
+- echo "| Please see the PHRED.DOC file for more information. |"; \
+- echo "| |"; \
+- echo "============================================================"; \
+- echo ""; \
+- exit 1; \
+- fi \
+- fi
++phred: $(OBJS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o phred $^ $(LIBS)
+
+
+ daev: daev.o
+- $(CC) $(CFLAGS) -o daev daev.o -lm
++ $(CC) $(LDFLAGS) $(CFLAGS) -o daev $^ $(LIBS)
+
+
+ clean:
diff --git a/sci-biology/phred/files/phred-071220-fix-qa.patch b/sci-biology/phred/files/phred-071220-fix-qa.patch
new file mode 100644
index 000000000000..ab4d2ea023f6
--- /dev/null
+++ b/sci-biology/phred/files/phred-071220-fix-qa.patch
@@ -0,0 +1,36 @@
+Fix implicit declarations:
+* daev.c: In function ‘processParameters’:
+* daev.c:849:14: warning: implicit declaration of function ‘isdigit’ [-Wimplicit-function-declaration]
+* if( !isdigit( argv[iarg][0] ) )
+
+--- a/autoPhred.c
++++ b/autoPhred.c
+@@ -57,6 +57,7 @@
+ static int xstrcmp();
+ #endif
+
++int freeMBRData( MBRData *mbrData );
+ #ifdef ANSI_C
+ int autoPhred( Option *option )
+ #else
+--- a/daev.c
++++ b/daev.c
+@@ -58,6 +58,7 @@
+ #include <sys/stat.h>
+ #include <time.h>
+ #include <math.h>
++#include <ctype.h>
+
+ #ifndef _WIN32
+ #include <dirent.h>
+--- a/mergedBaseRead.c
++++ b/mergedBaseRead.c
+@@ -63,7 +63,7 @@
+ Peak *peak;
+ Observed_peak *obs_peak;
+
+- static initFlag = 0;
++ static int initFlag = 0;
+ static char mchar[256][256];
+
+ if( initFlag == 0 )