summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 18:49:28 +0000
committerSam James <sam@gentoo.org>2022-03-20 18:50:51 +0000
commit0e456e888bc1895caf56c1ba4a44980117b6b5c8 (patch)
tree04ccf7c1ddb54ab54852ac83000064b65f950ee4 /sci-biology
parentsci-biology/blat: [QA] fix tc-get* quoting (diff)
downloadgentoo-0e456e888bc1895caf56c1ba4a44980117b6b5c8.tar.gz
gentoo-0e456e888bc1895caf56c1ba4a44980117b6b5c8.tar.bz2
gentoo-0e456e888bc1895caf56c1ba4a44980117b6b5c8.zip
sci-biology/fasta: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/fasta/fasta-36.3.8h-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-biology/fasta/fasta-36.3.8h-r1.ebuild b/sci-biology/fasta/fasta-36.3.8h-r1.ebuild
index 1c396edf4586..1cd7ca60dcde 100644
--- a/sci-biology/fasta/fasta-36.3.8h-r1.ebuild
+++ b/sci-biology/fasta/fasta-36.3.8h-r1.ebuild
@@ -27,11 +27,11 @@ src_prepare() {
use debug && append-flags -DDEBUG
- if [[ $(tc-getCC) == *icc* ]]; then
+ if [[ "$(tc-getCC)" == *icc* ]]; then
CC_ALT=icc
ALT="${ALT}_icc"
else
- CC_ALT=$(tc-getCC)
+ CC_ALT="$(tc-getCC)"
use x86 && ALT="32"
use amd64 && ALT="64"
fi
@@ -39,7 +39,7 @@ src_prepare() {
if use cpu_flags_x86_sse2 ; then
ALT="${ALT}_sse2"
append-flags -msse2
- [[ $(tc-getCC) == *icc* ]] || append-flags -ffast-math
+ [[ "$(tc-getCC)" == *icc* ]] || append-flags -ffast-math
fi
export CC_ALT="${CC_ALT}"