summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/fasta/fasta-36.3.8h-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-biology/fasta/fasta-36.3.8h-r1.ebuild b/sci-biology/fasta/fasta-36.3.8h-r1.ebuild
index 1c396edf4586..1cd7ca60dcde 100644
--- a/sci-biology/fasta/fasta-36.3.8h-r1.ebuild
+++ b/sci-biology/fasta/fasta-36.3.8h-r1.ebuild
@@ -27,11 +27,11 @@ src_prepare() {
use debug && append-flags -DDEBUG
- if [[ $(tc-getCC) == *icc* ]]; then
+ if [[ "$(tc-getCC)" == *icc* ]]; then
CC_ALT=icc
ALT="${ALT}_icc"
else
- CC_ALT=$(tc-getCC)
+ CC_ALT="$(tc-getCC)"
use x86 && ALT="32"
use amd64 && ALT="64"
fi
@@ -39,7 +39,7 @@ src_prepare() {
if use cpu_flags_x86_sse2 ; then
ALT="${ALT}_sse2"
append-flags -msse2
- [[ $(tc-getCC) == *icc* ]] || append-flags -ffast-math
+ [[ "$(tc-getCC)" == *icc* ]] || append-flags -ffast-math
fi
export CC_ALT="${CC_ALT}"