summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/PyMca/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/PyMca/files')
-rw-r--r--sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch40
-rw-r--r--sci-chemistry/PyMca/files/4.4.1_p1-impl-dec.patch12
-rw-r--r--sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch16
3 files changed, 68 insertions, 0 deletions
diff --git a/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch b/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch
new file mode 100644
index 000000000000..487a45963d21
--- /dev/null
+++ b/sci-chemistry/PyMca/files/4.4.1_p1-gentoo.patch
@@ -0,0 +1,40 @@
+diff --git a/setup.py b/setup.py
+index 0b0fa58..a4fdab6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -41,34 +41,8 @@ for line in file(os.path.join('PyMca', 'PyMcaMain.py')).readlines():
+ print "PyMca X-Ray Fluorescence Toolkit %s" % __version__
+ print
+
+-print "Type 'L' to view the license."
+-print "Type 'yes' to accept the terms of the license."
+-print "Type 'no' to decline the terms of the license."
+-print
+-
+-while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except KeyboardInterrupt:
+- raise SystemExit
+- except:
+- resp = ""
+-
+- resp = string.lower(string.strip(resp))
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(1)
+-
+- if resp == "l":
+- os.system("more LICENSE.GPL")
+-
+-
+ # Specify all the required PyMca data
+-data_files = [('PyMca', ['LICENSE.GPL',
+- 'PyMca/Scofield1973.dict',
++data_files = [('PyMca', ['PyMca/Scofield1973.dict',
+ 'PyMca/changelog.txt',
+ 'PyMca/McaTheory.cfg',
+ 'PyMca/PyMcaSplashImage.png',
diff --git a/sci-chemistry/PyMca/files/4.4.1_p1-impl-dec.patch b/sci-chemistry/PyMca/files/4.4.1_p1-impl-dec.patch
new file mode 100644
index 000000000000..ea37348066d2
--- /dev/null
+++ b/sci-chemistry/PyMca/files/4.4.1_p1-impl-dec.patch
@@ -0,0 +1,12 @@
+diff --git a/PyMca/specfile/src/sfwrite.c b/PyMca/specfile/src/sfwrite.c
+index 24df907..93c18e9 100755
+--- a/PyMca/specfile/src/sfwrite.c
++++ b/PyMca/specfile/src/sfwrite.c
+@@ -55,6 +55,7 @@
+ */
+ #include <SpecFile.h>
+ #include <SpecFileP.h>
++#include <unistd.h>
+
+ /*
+ * Declarations
diff --git a/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch b/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch
new file mode 100644
index 000000000000..81dfaf038fa6
--- /dev/null
+++ b/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch
@@ -0,0 +1,16 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 0a77cdf..e7ba643 100644
+--- a/setup.py
++++ b/setup.py
+@@ -55,7 +55,7 @@ packages = ['PyMca','PyMca.PyMcaPlugins', 'PyMca.tests']
+ py_modules = []
+
+ # Specify all the required PyMca data
+-data_files = [(PYMCA_DATA_DIR, ['LICENSE.GPL',
++data_files = [(PYMCA_DATA_DIR, [
+ 'PyMca/PyMcaData/Scofield1973.dict',
+ 'changelog.txt',
+ 'PyMca/PyMcaData/McaTheory.cfg',