summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-06-08 10:58:07 +0200
committerPacho Ramos <pacho@gentoo.org>2023-06-08 11:38:56 +0200
commit0d1b3a277ae6fe5b8167ab5e628b39ae67a35cfa (patch)
tree360ad694062f4670a7b113f8631048f263fb3dbb /sci-chemistry/dssp/dssp-4.3.1.ebuild
parentsci-libs/libcifpp: add 5.1.0 (diff)
downloadgentoo-0d1b3a277ae6fe5b8167ab5e628b39ae67a35cfa.tar.gz
gentoo-0d1b3a277ae6fe5b8167ab5e628b39ae67a35cfa.tar.bz2
gentoo-0d1b3a277ae6fe5b8167ab5e628b39ae67a35cfa.zip
sci-chemistry/dssp: add 4.3.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry/dssp/dssp-4.3.1.ebuild')
-rw-r--r--sci-chemistry/dssp/dssp-4.3.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/dssp-4.3.1.ebuild b/sci-chemistry/dssp/dssp-4.3.1.ebuild
new file mode 100644
index 000000000000..daf7c4f9314d
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/boost:=[zlib]
+ >=dev-libs/libmcfp-1.2.2
+ >=sci-libs/libcifpp-5.1.0
+"
+DEPEND=""
+RDEPEND="${BDEPEND}"
+
+src_configure() {
+ # gxrio not packaged
+ local mycmakeargs=(
+ -DBUILD_WEBSERVER=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if has_version "<=sci-chemistry/gromacs-2022"; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}