summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-13 19:41:10 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-13 19:41:48 +0200
commit4b72e59ed9b1fcdb1ab88ede59c9a863549c5295 (patch)
tree8fb7c03aea6f7951bcab5570fb34222cc0213d0c /sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild
parentmultilib.eclass: export PKG_CONFIG in multilib_toolchain_setup (diff)
downloadgentoo-4b72e59ed9b1fcdb1ab88ede59c9a863549c5295.tar.gz
gentoo-4b72e59ed9b1fcdb1ab88ede59c9a863549c5295.tar.bz2
gentoo-4b72e59ed9b1fcdb1ab88ede59c9a863549c5295.zip
sci-chemistry/mdtraj: Bump to 1.9.4
Closes: https://bugs.gentoo.org/711696 Closes: https://bugs.gentoo.org/718478 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild')
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild
new file mode 100644
index 000000000000..5537daa6a536
--- /dev/null
+++ b/sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Read, write and analyze MD trajectories with only a few lines of Python code"
+HOMEPAGE="http://mdtraj.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/astor[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+# Tests fail (in previous ebuild versions they weren't even run
+RESTRICT="test"
+
+python_prepare() {
+ sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
+ -i basesetup.py || die
+ distutils-r1_python_prepare_all
+}