summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/tinker/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/tinker/files')
-rw-r--r--sci-chemistry/tinker/files/5.1.09-Makefile.patch13
-rw-r--r--sci-chemistry/tinker/files/6-openmp.patch15
-rw-r--r--sci-chemistry/tinker/files/7.1.2-openmp.patch15
-rw-r--r--sci-chemistry/tinker/files/tinker-7.1.2-build.patch17
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/tinker/files/5.1.09-Makefile.patch b/sci-chemistry/tinker/files/5.1.09-Makefile.patch
new file mode 100644
index 000000000000..68a095add706
--- /dev/null
+++ b/sci-chemistry/tinker/files/5.1.09-Makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/make/Makefile b/make/Makefile
+index 221ab45..7634474 100644
+--- a/make/Makefile
++++ b/make/Makefile
+@@ -607,7 +607,7 @@ clean:
+ listing:
+ cat *.i *.f > tinker.txt
+
+-rename:
++rename: ${EXEFILES}
+ mv alchemy.x $(BINDIR)/alchemy
+ mv analyze.x $(BINDIR)/analyze
+ mv anneal.x $(BINDIR)/anneal
diff --git a/sci-chemistry/tinker/files/6-openmp.patch b/sci-chemistry/tinker/files/6-openmp.patch
new file mode 100644
index 000000000000..3666fbd0bfc4
--- /dev/null
+++ b/sci-chemistry/tinker/files/6-openmp.patch
@@ -0,0 +1,15 @@
+diff --git a/source/initial.f b/source/initial.f
+index 835f228..4099c74 100644
+--- a/source/initial.f
++++ b/source/initial.f
+@@ -73,8 +73,8 @@ c
+ c
+ c Intel compiler extensions to OpenMP standard
+ c
+-!$ call kmp_set_stacksize (2**30)
+-!$ call kmp_set_blocktime (0)
++! call kmp_set_stacksize (2**30)
++! call kmp_set_blocktime (0)
+ c
+ c values of machine precision constants
+ c
diff --git a/sci-chemistry/tinker/files/7.1.2-openmp.patch b/sci-chemistry/tinker/files/7.1.2-openmp.patch
new file mode 100644
index 000000000000..f3e8e2932b4a
--- /dev/null
+++ b/sci-chemistry/tinker/files/7.1.2-openmp.patch
@@ -0,0 +1,15 @@
+diff --git a/source/initial.f b/source/initial.f
+index 835f228..4099c74 100644
+--- a/source/initial.f
++++ b/source/initial.f
+@@ -73,8 +73,8 @@ c
+ c
+ c Intel compiler extensions to OpenMP standard
+ c
+-!$ call kmp_set_stacksize_s (2**28)
+-!$ call kmp_set_blocktime (0)
++! call kmp_set_stacksize_s (2**28)
++! call kmp_set_blocktime (0)
+ c
+ c values of machine precision constants
+ c
diff --git a/sci-chemistry/tinker/files/tinker-7.1.2-build.patch b/sci-chemistry/tinker/files/tinker-7.1.2-build.patch
new file mode 100644
index 000000000000..d6ef484b19a4
--- /dev/null
+++ b/sci-chemistry/tinker/files/tinker-7.1.2-build.patch
@@ -0,0 +1,17 @@
+ make/Makefile | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/make/Makefile b/make/Makefile
+index 61d5037..9be384a 100644
+--- a/make/Makefile
++++ b/make/Makefile
+@@ -719,8 +719,7 @@ EXEFILES = alchemy.x \
+ %.x: %.o libtinker.a
+ ${F77} ${LINKFLAGS} -o $@ $^ ${LIBS}; strip $@
+
+-all:
+- ${EXEFILES}
++all: ${EXEFILES}
+
+ install:
+ rename