summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/tinker/files')
-rw-r--r--sci-chemistry/tinker/files/5.1.09-Makefile.patch13
-rw-r--r--sci-chemistry/tinker/files/6-openmp.patch15
-rw-r--r--sci-chemistry/tinker/files/7.1.2-openmp.patch15
-rw-r--r--sci-chemistry/tinker/files/tinker-7.1.2-build.patch17
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/tinker/files/5.1.09-Makefile.patch b/sci-chemistry/tinker/files/5.1.09-Makefile.patch
new file mode 100644
index 000000000000..68a095add706
--- /dev/null
+++ b/sci-chemistry/tinker/files/5.1.09-Makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/make/Makefile b/make/Makefile
+index 221ab45..7634474 100644
+--- a/make/Makefile
++++ b/make/Makefile
+@@ -607,7 +607,7 @@ clean:
+ listing:
+ cat *.i *.f > tinker.txt
+
+-rename:
++rename: ${EXEFILES}
+ mv alchemy.x $(BINDIR)/alchemy
+ mv analyze.x $(BINDIR)/analyze
+ mv anneal.x $(BINDIR)/anneal
diff --git a/sci-chemistry/tinker/files/6-openmp.patch b/sci-chemistry/tinker/files/6-openmp.patch
new file mode 100644
index 000000000000..3666fbd0bfc4
--- /dev/null
+++ b/sci-chemistry/tinker/files/6-openmp.patch
@@ -0,0 +1,15 @@
+diff --git a/source/initial.f b/source/initial.f
+index 835f228..4099c74 100644
+--- a/source/initial.f
++++ b/source/initial.f
+@@ -73,8 +73,8 @@ c
+ c
+ c Intel compiler extensions to OpenMP standard
+ c
+-!$ call kmp_set_stacksize (2**30)
+-!$ call kmp_set_blocktime (0)
++! call kmp_set_stacksize (2**30)
++! call kmp_set_blocktime (0)
+ c
+ c values of machine precision constants
+ c
diff --git a/sci-chemistry/tinker/files/7.1.2-openmp.patch b/sci-chemistry/tinker/files/7.1.2-openmp.patch
new file mode 100644
index 000000000000..f3e8e2932b4a
--- /dev/null
+++ b/sci-chemistry/tinker/files/7.1.2-openmp.patch
@@ -0,0 +1,15 @@
+diff --git a/source/initial.f b/source/initial.f
+index 835f228..4099c74 100644
+--- a/source/initial.f
++++ b/source/initial.f
+@@ -73,8 +73,8 @@ c
+ c
+ c Intel compiler extensions to OpenMP standard
+ c
+-!$ call kmp_set_stacksize_s (2**28)
+-!$ call kmp_set_blocktime (0)
++! call kmp_set_stacksize_s (2**28)
++! call kmp_set_blocktime (0)
+ c
+ c values of machine precision constants
+ c
diff --git a/sci-chemistry/tinker/files/tinker-7.1.2-build.patch b/sci-chemistry/tinker/files/tinker-7.1.2-build.patch
new file mode 100644
index 000000000000..d6ef484b19a4
--- /dev/null
+++ b/sci-chemistry/tinker/files/tinker-7.1.2-build.patch
@@ -0,0 +1,17 @@
+ make/Makefile | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/make/Makefile b/make/Makefile
+index 61d5037..9be384a 100644
+--- a/make/Makefile
++++ b/make/Makefile
+@@ -719,8 +719,7 @@ EXEFILES = alchemy.x \
+ %.x: %.o libtinker.a
+ ${F77} ${LINKFLAGS} -o $@ $^ ${LIBS}; strip $@
+
+-all:
+- ${EXEFILES}
++all: ${EXEFILES}
+
+ install:
+ rename