summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-08 11:01:18 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-08 11:01:26 -0400
commitc0e3ab5a829f86e167d3f5d498e1382af8359816 (patch)
treef76d991faaf475a44e8f73c2d57376799756e80a /sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild
parentgnome-base/gnome-desktop: Version bump to 42.4 (diff)
downloadgentoo-c0e3ab5a829f86e167d3f5d498e1382af8359816.tar.gz
gentoo-c0e3ab5a829f86e167d3f5d498e1382af8359816.tar.bz2
gentoo-c0e3ab5a829f86e167d3f5d498e1382af8359816.zip
sci-geosciences/geocode-glib: Version bump to 3.26.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild')
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild
new file mode 100644
index 000000000000..7d4b96f4ae1a
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.26.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson xdg
+
+DESCRIPTION="GLib helper library for geocoding services"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/geocode-glib"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Denable-installed-tests=false
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Dsoup2=true
+ )
+ meson_src_configure
+}