summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/alglib/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/alglib/files')
-rw-r--r--sci-libs/alglib/files/CMakeLists.txt32
-rw-r--r--sci-libs/alglib/files/CMakeLists.txt-3.8.236
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/alglib/files/CMakeLists.txt b/sci-libs/alglib/files/CMakeLists.txt
new file mode 100644
index 000000000000..6455423b0fe9
--- /dev/null
+++ b/sci-libs/alglib/files/CMakeLists.txt
@@ -0,0 +1,32 @@
+project(alglib CXX)
+cmake_minimum_required(VERSION 2.8)
+
+INCLUDE(GNUInstallDirs)
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/src)
+SET(VERSION 3.7.0)
+SET(SOVERSION 3.7)
+
+FILE(GLOB ALGLIB_SRC_LIB "src/*.cpp")
+FILE(GLOB ALGLIB_HDR_LIB "src/*.h")
+
+ADD_LIBRARY(alglib SHARED ${ALGLIB_SRC_LIB})
+SET_TARGET_PROPERTIES(alglib PROPERTIES
+ VERSION ${VERSION}
+ SOVERSION ${SOVERSION})
+
+INSTALL(TARGETS alglib DESTINATION ${CMAKE_INSTALL_LIBDIR}/)
+INSTALL(FILES ${ALGLIB_HDR_LIB} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+#===========================================================
+ADD_EXECUTABLE(test_c tests/test_c.cpp)
+TARGET_LINK_LIBRARIES(test_c alglib)
+#INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+#===========================================================
+ADD_EXECUTABLE(test_i tests/test_i.cpp)
+TARGET_LINK_LIBRARIES(test_i alglib)
+#INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+#===========================================================
+
+enable_testing()
+add_test( test_c ${CMAKE_BUILD_DIR}/test_c)
+add_test( test_i ${CMAKE_BUILD_DIR}/test_i)
diff --git a/sci-libs/alglib/files/CMakeLists.txt-3.8.2 b/sci-libs/alglib/files/CMakeLists.txt-3.8.2
new file mode 100644
index 000000000000..483c63dc7f59
--- /dev/null
+++ b/sci-libs/alglib/files/CMakeLists.txt-3.8.2
@@ -0,0 +1,36 @@
+project(alglib CXX)
+cmake_minimum_required(VERSION 2.8)
+
+INCLUDE(GNUInstallDirs)
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/src)
+SET(VERSION 3.8.2)
+SET(SOVERSION 3.8)
+
+option(BUILD_TEST "Build tests" OFF)
+
+FILE(GLOB ALGLIB_SRC_LIB "src/*.cpp")
+FILE(GLOB ALGLIB_HDR_LIB "src/*.h")
+
+ADD_LIBRARY(alglib SHARED ${ALGLIB_SRC_LIB})
+SET_TARGET_PROPERTIES(alglib PROPERTIES
+ VERSION ${VERSION}
+ SOVERSION ${SOVERSION})
+
+INSTALL(TARGETS alglib DESTINATION ${CMAKE_INSTALL_LIBDIR}/)
+INSTALL(FILES ${ALGLIB_HDR_LIB} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+if (BUILD_TEST)
+ #===========================================================
+ ADD_EXECUTABLE(test_c tests/test_c.cpp)
+ TARGET_LINK_LIBRARIES(test_c alglib)
+ #INSTALL(TARGETS test_c DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+ #===========================================================
+ ADD_EXECUTABLE(test_i tests/test_i.cpp)
+ TARGET_LINK_LIBRARIES(test_i alglib)
+ #INSTALL(TARGETS test_i DESTINATION ${CMAKE_INSTALL_BINDIR}/)
+ #===========================================================
+
+ enable_testing()
+endif (BUILD_TEST)
+add_test( test_c ${CMAKE_BUILD_DIR}/test_c)
+add_test( test_i ${CMAKE_BUILD_DIR}/test_i)