summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-06-15 18:17:24 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-06-16 20:03:18 -0500
commit161fc86a9bdc9277f26b023de5e422bb5d56c2b8 (patch)
tree2ed0d1fd2a01216f282337029f14619cc4872afc /sci-libs/arborx/arborx-1.4.1-r1.ebuild
parentkde-misc/tellico: Stabilize 3.5 amd64, #908606 (diff)
downloadgentoo-161fc86a9bdc9277f26b023de5e422bb5d56c2b8.tar.gz
gentoo-161fc86a9bdc9277f26b023de5e422bb5d56c2b8.tar.bz2
gentoo-161fc86a9bdc9277f26b023de5e422bb5d56c2b8.zip
sci-libs/arborx: fix libdir
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/arborx/arborx-1.4.1-r1.ebuild')
-rw-r--r--sci-libs/arborx/arborx-1.4.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/arborx/arborx-1.4.1-r1.ebuild b/sci-libs/arborx/arborx-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..d0d4cf0e2ed2
--- /dev/null
+++ b/sci-libs/arborx/arborx-1.4.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Library for performance portable algorithms for geometric search"
+HOMEPAGE="https://github.com/arborx/ArborX"
+
+SRC_URI="https://github.com/${PN}/ArborX/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="mpi"
+
+RDEPEND="dev-libs/boost:=
+ mpi? ( virtual/mpi[cxx] )
+ sci-libs/trilinos"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/ArborX-${PV}
+
+src_prepare() {
+ default
+ cmake_src_prepare
+
+ # replace hardcoded "lib/" directory:
+ sed -i -e "s#lib/#$(get_libdir)/#g" CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DARBORX_ENABLE_MPI="$(usex mpi)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}