summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-08-01 15:12:43 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-08-01 15:12:43 +0200
commit90d74393cb702bfac6542c9edbf5fca4b43984ba (patch)
tree98467fa42675a54ec9331fdfa800e1b0aba68c49 /sci-libs/branca/branca-0.4.2.ebuild
parentsci-geosciences/geopy: geocoding library for python (diff)
downloadgentoo-90d74393cb702bfac6542c9edbf5fca4b43984ba.tar.gz
gentoo-90d74393cb702bfac6542c9edbf5fca4b43984ba.tar.bz2
gentoo-90d74393cb702bfac6542c9edbf5fca4b43984ba.zip
sci-libs/branca: Add to tree
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/branca/branca-0.4.2.ebuild')
-rw-r--r--sci-libs/branca/branca-0.4.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/branca/branca-0.4.2.ebuild b/sci-libs/branca/branca-0.4.2.ebuild
new file mode 100644
index 000000000000..827ed2ca9acb
--- /dev/null
+++ b/sci-libs/branca/branca-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features."
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="${HOMEPAGE}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not headless'
+}