summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-07-23 10:42:28 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-08-21 18:13:18 +0200
commit4542551ff511e1d11282c5208f383e19dd944f43 (patch)
tree07a54814d7f7c6148b54453ab4125c7a58dff6d9 /sci-libs/fcl/fcl-0.6.1.ebuild
parentdev-perl/File-BaseDir: Bump to version 0.80.0 (diff)
downloadgentoo-4542551ff511e1d11282c5208f383e19dd944f43.tar.gz
gentoo-4542551ff511e1d11282c5208f383e19dd944f43.tar.bz2
gentoo-4542551ff511e1d11282c5208f383e19dd944f43.zip
sci-libs/fcl: bump to 0.6.1
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/16787 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sci-libs/fcl/fcl-0.6.1.ebuild')
-rw-r--r--sci-libs/fcl/fcl-0.6.1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sci-libs/fcl/fcl-0.6.1.ebuild b/sci-libs/fcl/fcl-0.6.1.ebuild
new file mode 100644
index 000000000000..8c1a80c0eb37
--- /dev/null
+++ b/sci-libs/fcl/fcl-0.6.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+DESCRIPTION="The Flexible Collision Library"
+HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+
+LICENSE="BSD"
+SLOT="0/6"
+IUSE="cpu_flags_x86_sse doc +octomap profiling test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/boost:=[threads]
+ sci-libs/flann
+ sci-libs/libccd[double-precision]
+ octomap? ( sci-libs/octomap )
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-cpp/gtest )"
+
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ # Upstream issue:
+ # https://github.com/flexible-collision-library/fcl/issues/485
+ rm "${S}"/test/narrowphase/detail/convexity_based_algorithm/test_gjk_libccd-inl_gjk_doSimplex2.cpp
+ sed -i -e 's/test_gjk_libccd-inl_gjk_doSimplex2.cpp//' "${S}"/test/narrowphase/detail/convexity_based_algorithm/CMakeLists.txt || die could not disable failing test
+
+ sed -i -e "s/include(CompilerSettings)//" "${S}"/CMakeLists.txt || die "failed to remove compiler flags override"
+
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DFCL_COVERALLS=OFF
+ -DFCL_COVERALLS_UPLOAD=OFF
+ -DFCL_ENABLE_PROFILING=$(usex profiling ON OFF)
+ -DFCL_TREAT_WARNINGS_AS_ERRORS=OFF
+ -DFCL_USE_HOST_NATIVE_ARCH=OFF
+ -DFCL_USE_X64_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DFCL_WITH_OCTOMAP=$(usex octomap ON OFF)
+ )
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && HTML_DOCS=( "${S}"/doc/doxygen/html )
+ einstalldocs
+}