summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2023-01-15 14:40:57 +1300
committerMichael Orlitzky <mjo@gentoo.org>2023-01-16 12:35:58 -0500
commit7a1d52341009e2cf2c218684bc7ff3da14e94118 (patch)
tree6cfe8a1aa169b700fd1dd8cf220a33b6478fa208 /sci-libs/fplll/fplll-5.4.4.ebuild
parentdev-libs/newt: remove unused patches (diff)
downloadgentoo-7a1d52341009e2cf2c218684bc7ff3da14e94118.tar.gz
gentoo-7a1d52341009e2cf2c218684bc7ff3da14e94118.tar.bz2
gentoo-7a1d52341009e2cf2c218684bc7ff3da14e94118.zip
sci-libs/fplll: add 5.4.4
Closes: https://github.com/gentoo/gentoo/pull/29113 Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Signed-off-by: François Bissey <frp.bissey@gmail.com>
Diffstat (limited to 'sci-libs/fplll/fplll-5.4.4.ebuild')
-rw-r--r--sci-libs/fplll/fplll-5.4.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/fplll/fplll-5.4.4.ebuild b/sci-libs/fplll/fplll-5.4.4.ebuild
new file mode 100644
index 000000000000..d8ad2144d60b
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8"
+KEYWORDS="~amd64 ~x86"
+IUSE="qd"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0
+ qd? ( sci-libs/qd )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with qd)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}