summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-26 17:23:50 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-26 17:23:50 +0100
commit2d97594dad4854ffb0a0045b0d4c2279bbbb30d6 (patch)
tree419e3ec8933bf559e1d1b422bf785b633baf4ae0 /sci-libs/libexcelformat
parentsci-libs/idlmarkwardt: update EAPI 6 -> 8 (diff)
downloadgentoo-2d97594dad4854ffb0a0045b0d4c2279bbbb30d6.tar.gz
gentoo-2d97594dad4854ffb0a0045b0d4c2279bbbb30d6.tar.bz2
gentoo-2d97594dad4854ffb0a0045b0d4c2279bbbb30d6.zip
sci-libs/libexcelformat: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/731886 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/libexcelformat')
-rw-r--r--sci-libs/libexcelformat/files/libexcelformat-101016-Wliteral-suffix.patch13
-rw-r--r--sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild (renamed from sci-libs/libexcelformat/libexcelformat-101016.ebuild)14
2 files changed, 19 insertions, 8 deletions
diff --git a/sci-libs/libexcelformat/files/libexcelformat-101016-Wliteral-suffix.patch b/sci-libs/libexcelformat/files/libexcelformat-101016-Wliteral-suffix.patch
new file mode 100644
index 000000000000..9ce8f4a7aa85
--- /dev/null
+++ b/sci-libs/libexcelformat/files/libexcelformat-101016-Wliteral-suffix.patch
@@ -0,0 +1,13 @@
+Fix -Wliteral-suffix (#731886)
+
+--- a/BasicExcel.cpp
++++ b/BasicExcel.cpp
+@@ -4913,7 +4913,7 @@
+ do
+ {
+ char sname[50];
+- sprintf(sname, "Sheet"FMT_SIZE_T, sheetNo++);
++ sprintf(sname, "Sheet" FMT_SIZE_T, sheetNo++);
+ yesheet = AddWorksheet(sname, sheetIndex);
+ } while (!yesheet);
+ return yesheet;
diff --git a/sci-libs/libexcelformat/libexcelformat-101016.ebuild b/sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild
index c3014bcdc051..23fb0ef4f630 100644
--- a/sci-libs/libexcelformat/libexcelformat-101016.ebuild
+++ b/sci-libs/libexcelformat/libexcelformat-101016-r1.ebuild
@@ -1,28 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="reading, writing, and editing of XLS (BIFF8 format) files using C++"
HOMEPAGE="https://www.codeproject.com/Articles/42504/ExcelFormat-Library"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}/libExcelFormat"
+LICENSE="CPOL"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="CPOL"
-IUSE=""
-S="${WORKDIR}"/libExcelFormat
+PATCHES=( "${FILESDIR}"/${P}-Wliteral-suffix.patch )
-src_prepare() {
- default
+src_configure() {
tc-export CXX
}
src_install() {
doheader *.h*
-
dolib.so libExcelFormat.so*
}