summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-03 22:56:48 +0200
committerDavid Seifert <soap@gentoo.org>2020-10-03 22:56:48 +0200
commit70e54e5cb41aa1e47a661350b9590802d6f88525 (patch)
treedfc9e75ae6f556a93d5efe23654e1a4afb321d9b /sci-libs
parentsci-libs/libecpint: initial commit (diff)
downloadgentoo-70e54e5cb41aa1e47a661350b9590802d6f88525.tar.gz
gentoo-70e54e5cb41aa1e47a661350b9590802d6f88525.tar.bz2
gentoo-70e54e5cb41aa1e47a661350b9590802d6f88525.zip
sci-libs/xylib: Version bump to 1.6
Bug: https://bugs.gentoo.org/723326 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/xylib/Manifest1
-rw-r--r--sci-libs/xylib/xylib-1.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/xylib/Manifest b/sci-libs/xylib/Manifest
index 63c79c4b23ae..6e87010ef9c0 100644
--- a/sci-libs/xylib/Manifest
+++ b/sci-libs/xylib/Manifest
@@ -1 +1,2 @@
DIST xylib-1.2.tar.bz2 297167 BLAKE2B f30a397aea282626b2e5ea93053571ed6d617b4fdeff468751fed9c9f538595854c948d0f50656ce22dbadfe4ff99a59dc4a5fb70686e78c084bbe1db1c9c11a SHA512 16eaa4b37014914c75ca3d0188aaf236c342887c03e233a9bb770412b3bb16da6779ab82c8acd66677d98ada75537c77d1abad723defd33dbe6eda78c6c88b91
+DIST xylib-1.6.tar.bz2 370765 BLAKE2B 76eb968f06a6a015ed7a29a493d888642767cda103733498b8706c973498aa4ac8576716b06f6eae8d95a1f625e9cd91ab02cfd53146d976e32fc9295f3c502f SHA512 9861cbf03f8b921a93a2d32a529ff94d77723e2510cd61096b4b85f91af4be6330ed82e8da94bc45dbca7f9814077360d1dae204315b28c2b6d85e3d2c7f6696
diff --git a/sci-libs/xylib/xylib-1.6.ebuild b/sci-libs/xylib/xylib-1.6.ebuild
new file mode 100644
index 000000000000..49e226d26949
--- /dev/null
+++ b/sci-libs/xylib/xylib-1.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER=3.0-gtk3
+
+inherit wxwidgets
+
+DESCRIPTION="Experimental x-y data reading library"
+HOMEPAGE="https://github.com/wojdyr/xylib"
+SRC_URI="https://github.com/wojdyr/xylib/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 gui zlib"
+
+RDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ gui? ( x11-libs/wxGTK:${WX_GTK_VER} )
+ zlib? ( sys-libs/zlib )"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost"
+
+src_configure() {
+ use gui && setup-wxwidgets
+
+ econf \
+ --disable-static \
+ $(use_with bzip2 bzlib) \
+ $(use_with gui) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}