summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-10 17:41:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-10 18:34:47 +0100
commitf10b7c7c5f4348966272229d4282fe4463004100 (patch)
treed2157334a5d45e9c0ca4cc436d438538280fd78a /sci-libs
parentsci-libs/rtabmap: fix buidl with opencv4 (diff)
downloadgentoo-f10b7c7c5f4348966272229d4282fe4463004100.tar.gz
gentoo-f10b7c7c5f4348966272229d4282fe4463004100.tar.bz2
gentoo-f10b7c7c5f4348966272229d4282fe4463004100.zip
sci-libs/rtabmap: update to eapi7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rtabmap/rtabmap-0.19.3-r1.ebuild (renamed from sci-libs/rtabmap/rtabmap-0.19.3.ebuild)6
-rw-r--r--sci-libs/rtabmap/rtabmap-9999.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/sci-libs/rtabmap/rtabmap-0.19.3.ebuild b/sci-libs/rtabmap/rtabmap-0.19.3-r1.ebuild
index a76c02847b15..df3b781baf72 100644
--- a/sci-libs/rtabmap/rtabmap-0.19.3.ebuild
+++ b/sci-libs/rtabmap/rtabmap-0.19.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -42,8 +42,8 @@ RDEPEND="
dev-qt/qtsvg:5
)
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}/ocv4.patch" )
src_configure() {
diff --git a/sci-libs/rtabmap/rtabmap-9999.ebuild b/sci-libs/rtabmap/rtabmap-9999.ebuild
index 0a88ca05e482..24cbe5a01b96 100644
--- a/sci-libs/rtabmap/rtabmap-9999.ebuild
+++ b/sci-libs/rtabmap/rtabmap-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -42,8 +42,8 @@ RDEPEND="
dev-qt/qtsvg:5
)
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_configure() {
local mycmakeargs=(