summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-03 07:19:00 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-03 07:20:02 +0100
commitfa97825f64cac2d8ae1fe93f8bf5d1c6abc75930 (patch)
tree52828fd710280a5203a9acfef12e614c434389c1 /sci-libs
parentsci-libs/caffe2: inherit single and mv api in python dir (diff)
downloadgentoo-fa97825f64cac2d8ae1fe93f8bf5d1c6abc75930.tar.gz
gentoo-fa97825f64cac2d8ae1fe93f8bf5d1c6abc75930.tar.bz2
gentoo-fa97825f64cac2d8ae1fe93f8bf5d1c6abc75930.zip
sci-libs/pytorch: use single python class
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pytorch/pytorch-1.12.0-r2.ebuild (renamed from sci-libs/pytorch/pytorch-1.12.0-r1.ebuild)13
1 files changed, 9 insertions, 4 deletions
diff --git a/sci-libs/pytorch/pytorch-1.12.0-r1.ebuild b/sci-libs/pytorch/pytorch-1.12.0-r2.ebuild
index 02fa58c7ba75..83a4944773f1 100644
--- a/sci-libs/pytorch/pytorch-1.12.0-r1.ebuild
+++ b/sci-libs/pytorch/pytorch-1.12.0-r2.ebuild
@@ -1,10 +1,11 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
DESCRIPTION="Tensors and Dynamic neural networks in Python"
@@ -20,11 +21,15 @@ RESTRICT="test"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="
${PYTHON_DEPS}
- ~sci-libs/caffe2-${PV}[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ~sci-libs/caffe2-${PV}[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ')
"
DEPEND="${RDEPEND}
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ')
"
src_prepare() {