summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/oww/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/oww/files')
-rw-r--r--sci-misc/oww/files/oww-0.86.4-build.patch79
-rw-r--r--sci-misc/oww/files/oww-0.86.5-format-security.patch30
2 files changed, 109 insertions, 0 deletions
diff --git a/sci-misc/oww/files/oww-0.86.4-build.patch b/sci-misc/oww/files/oww-0.86.4-build.patch
new file mode 100644
index 000000000000..19f96a0c8551
--- /dev/null
+++ b/sci-misc/oww/files/oww-0.86.4-build.patch
@@ -0,0 +1,79 @@
+ Makefile.am | 3 +--
+ configure.in | 15 ++++++++-------
+ src/Makefile.am | 2 +-
+ 3 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index f90cc9d..36495a7 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,10 +5,9 @@
+
+ SUBDIRS = src pixmaps po
+
+-owwdocdir = ${prefix}/doc/oww
++owwdocdir = ${docdir}
+ owwdoc_DATA = \
+ README\
+- COPYING\
+ AUTHORS\
+ ChangeLog\
+ INSTALL\
+diff --git a/configure.in b/configure.in
+index dbc694e..a9c779f 100644
+--- a/configure.in
++++ b/configure.in
+@@ -6,6 +6,8 @@ AM_INIT_AUTOMAKE
+
+ AM_CONFIG_HEADER(config.h)
+
++AC_CONFIG_MACRO_DIR([.])
++
+ AC_ISC_POSIX
+ dnl CFLAGS=""
+ AC_SUBST(CFLAGS)
+@@ -134,17 +136,16 @@ else
+ AC_MSG_WARN(interactive CLI will not be build)
+ fi
+
+-AC_ARG_ENABLE(gui, , build_gui=no, build_gui=yes)
+-AM_CONDITIONAL(DISABLEGUI, test "x$build_gui" = "xno")
++AC_ARG_ENABLE([gui],AS_HELP_STRING([--disable-gui], [Do not build gtk gui]))
+
+-if test "$build_gui" = yes ; then
++AM_CONDITIONAL([DISABLEGUI], [test "x$enable_gui" != "xyes"])
++
++AS_IF([test "x$enable_gui" != "xno"], [
+ AC_MSG_WARN(building gui)
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.4.0 gdk-2.0 gdk-pixbuf-2.0 gmodule-export-2.0,,exit)
+ AC_SUBST(GTK_LIBS)
+ AC_SUBST(GTK_CFLAGS)
+-else
+- AC_MSG_WARN(skipping GTK gui)
+-fi
++])
+
+ dnl How many times do we retry T on failure?
+ AC_ARG_ENABLE(temptries,
+@@ -319,7 +320,7 @@ cat<<EOF
+ ------------------------------
+ Oww version $VERSION by Simon Melhuish (simon@melhuish.info)
+
+- build_gui = $build_gui
++ build_gui = $xgui
+ interactive = $interactive
+ seriallock = $seriallock
+ USB support = $usb_msg
+diff --git a/src/Makefile.am b/src/Makefile.am
+index e0f6746..c02aab5 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2,7 +2,7 @@
+
+ # Needs USB_CFLAGS here else things like musbllnk compile will fail if usb.h
+ # isn't in the compilers standard include path.
+-INCLUDES = \
++AM_CPPFLAGS = \
+ $(USB_CFLAGS)\
+ $(GTK_CFLAGS)
+
diff --git a/sci-misc/oww/files/oww-0.86.5-format-security.patch b/sci-misc/oww/files/oww-0.86.5-format-security.patch
new file mode 100644
index 000000000000..190c637e1983
--- /dev/null
+++ b/sci-misc/oww/files/oww-0.86.5-format-security.patch
@@ -0,0 +1,30 @@
+ src/file.c | 2 +-
+ src/werr_linux.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/file.c b/src/file.c
+index 9726564..af2f672 100644
+--- a/src/file.c
++++ b/src/file.c
+@@ -152,7 +152,7 @@ int file_check_file(char *file_name, int create)
+
+ fp = fopen(file_name, "w") ;
+ if (!fp) return 0 ;
+- fprintf(fp, setup_format_loghead) ;
++ fprintf(fp, "%s", setup_format_loghead) ;
+ fprintf(fp, "\n") ;
+ fclose(fp) ;
+ return 1 ;
+diff --git a/src/werr_linux.c b/src/werr_linux.c
+index 50d3993..0f8834e 100644
+--- a/src/werr_linux.c
++++ b/src/werr_linux.c
+@@ -331,7 +331,7 @@ void werr(int flags, char* format, ...)
+ else
+ syslog_level = LOG_DEBUG ;
+
+- syslog(syslog_level, message) ;
++ syslog(syslog_level, "%s", message) ;
+ }
+ # endif
+ # else // i.e. ifndef NOGUI