summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r4.ebuild')
-rw-r--r--sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r4.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r4.ebuild b/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r4.ebuild
new file mode 100644
index 000000000000..47893126ffb8
--- /dev/null
+++ b/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils fortran-2 toolchain-funcs
+
+DEB_PN=mclibs
+DEB_PV=20061220+dfsg3
+DEB_PR=3
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="Monte-carlo library and tools for the cernlib"
+HOMEPAGE="https://cernlib.web.cern.ch/cernlib/"
+SRC_URI="
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.debian.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2 BSD"
+IUSE="+herwig"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ x11-libs/motif:0
+ dev-lang/cfortran
+ sci-physics/cernlib
+ herwig? ( !sci-physics/herwig )"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+src_prepare() {
+ mv ../debian . || die
+ cp debian/add-ons/Makefile . || die
+ export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
+ sed -i \
+ -e "s:/usr/local:${EROOT}/usr:g" \
+ Makefile || die
+
+ einfo "Applying Debian patches"
+ emake -j1 patch
+ use herwig || epatch "${FILESDIR}"/${P}-noherwig.patch
+ # since we depend on cfortran, do not use the one from cernlib
+ rm src/include/cfortran/cfortran.h || die
+ # respect users flags
+ sed -i \
+ -e 's/-O3/-O2/g' \
+ -e "s/-O2/${CFLAGS}/g" \
+ -e "s|\(CcCmd[[:space:]]*\)gcc|\1$(tc-getCC)|g" \
+ -e "s|\(CplusplusCmd[[:space:]]*\)g++|\1$(tc-getCXX)|g" \
+ -e "s|\(FortranCmd[[:space:]]*\)gfortran|\1$(tc-getFC)|g" \
+ src/config/linux.cf \
+ || die "sed linux.cf failed"
+ sed -i \
+ -e "s|\(ArCmdBase[[:space:]]*\)ar|\1$(tc-getAR)|g" \
+ -e "s|\(RanlibCmd[[:space:]]*\)ranlib|\1$(tc-getRANLIB)|g" \
+ src/config/Imake.tmpl \
+ || die "sed Imake.tmpl failed"
+
+ sed -i \
+ -e 's/\$(FCLINK)/\$(FCLINK) $(LDFLAGS)/' \
+ -e 's/\$(CCLINK)/\$(CCLINK) $(LDFLAGS)/' \
+ src/config/{biglib,fortran,Imake}.rules \
+ || die "sed for ldflags propagation failed"
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake -j1 cernlib-indep cernlib-arch
+}
+
+src_test() {
+ export VARTEXFONTS="${T}"/fonts
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test
+}
+
+src_install() {
+ emake DESTDIR="${D}" MCDOC="${ED}usr/share/doc/${PF}" install
+ cd debian
+ dodoc changelog README.* deadpool.txt copyright
+ newdoc add-ons/README README.add-ons
+}