summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-physics/geant/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-physics/geant/files')
-rw-r--r--sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch60
-rw-r--r--sci-physics/geant/files/geant-4.10.0-no-examples.patch22
-rw-r--r--sci-physics/geant/files/geant-4.9.4-datadir.patch43
-rw-r--r--sci-physics/geant/files/geant-4.9.4-libdir.patch35
-rw-r--r--sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch10
-rw-r--r--sci-physics/geant/files/geant-4.9.4-no-examples.patch15
-rw-r--r--sci-physics/geant/files/geant-4.9.4-trajectory.patch11
-rw-r--r--sci-physics/geant/files/geant-4.9.4-zlib.patch35
8 files changed, 231 insertions, 0 deletions
diff --git a/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch b/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch
new file mode 100644
index 000000000000..e3cc8d6594a5
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.10.0-TrackingNavigator.patch
@@ -0,0 +1,60 @@
+accepted upstream. to be removed in the next minor release.
+
+https://bugs.gentoo.org/show_bug.cgi?id=496678
+http://bugzilla-geant4.kek.jp/show_bug.cgi?id=1537
+
+diff -Naur geant4.10.00/source/geometry/navigation/include/G4TransportationManager.hh geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.hh
+--- geant4.10.00/source/geometry/navigation/include/G4TransportationManager.hh 2013-12-05 10:28:54.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.hh 2013-12-12 01:40:12.341428809 +0100
+@@ -68,7 +68,7 @@
+ // Accessors for field handling
+
+ inline G4Navigator* GetNavigatorForTracking() const;
+- inline void SetNavigatorForTracking( G4Navigator* newNavigator );
++ void SetNavigatorForTracking( G4Navigator* newNavigator );
+ // Accessors for the navigator for tracking
+
+ inline void SetWorldForTracking(G4VPhysicalVolume* theWorld);
+diff -Naur geant4.10.00/source/geometry/navigation/include/G4TransportationManager.icc geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.icc
+--- geant4.10.00/source/geometry/navigation/include/G4TransportationManager.icc 2013-12-05 10:28:54.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/include/G4TransportationManager.icc 2013-12-12 01:40:12.341428809 +0100
+@@ -59,6 +59,7 @@
+ fNavigators[0]->SetWorldVolume(theWorld);
+ }
+
++/*
+ // ----------------------------------------------------------------------------
+ // SetNavigatorForTracking()
+ //
+@@ -70,6 +71,7 @@
+ {
+ fNavigators[0] = newNavigator;
+ }
++*/
+
+ // ----------------------------------------------------------------------------
+ // GetPropagatorInField()
+diff -Naur geant4.10.00/source/geometry/navigation/src/G4TransportationManager.cc geant4.10.00-mod/source/geometry/navigation/src/G4TransportationManager.cc
+--- geant4.10.00/source/geometry/navigation/src/G4TransportationManager.cc 2013-12-05 10:28:56.000000000 +0100
++++ geant4.10.00-mod/source/geometry/navigation/src/G4TransportationManager.cc 2013-12-12 01:40:12.345428679 +0100
+@@ -124,6 +124,20 @@
+ }
+ }
+
++
++// ----------------------------------------------------------------------------
++// SetNavigatorForTracking()
++//
++// Set the active navigator for tracking, always
++// the first in the collection of registered navigators.
++//
++void G4TransportationManager::SetNavigatorForTracking(G4Navigator* newNavigator)
++{
++ fNavigators[0] = newNavigator;
++ fActiveNavigators[0] = newNavigator;
++ fPropagatorInField->SetNavigatorForPropagating(newNavigator);
++}
++
+ // ----------------------------------------------------------------------------
+ // ClearNavigators()
+ //
diff --git a/sci-physics/geant/files/geant-4.10.0-no-examples.patch b/sci-physics/geant/files/geant-4.10.0-no-examples.patch
new file mode 100644
index 000000000000..99aaca546f49
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.10.0-no-examples.patch
@@ -0,0 +1,22 @@
+do not install examples automatically, we do this explictly with dodoc.
+
+Index: geant4.10.00/CMakeLists.txt
+===================================================================
+--- geant4.10.00.orig/CMakeLists.txt
++++ geant4.10.00/CMakeLists.txt
+@@ -136,15 +136,6 @@ if(GEANT4_BUILD_EXAMPLES)
+ add_subdirectory(examples)
+ endif()
+
+-# - Install example code to datarootdir
+-install(DIRECTORY examples
+- DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/Geant4-${Geant4_VERSION}
+- COMPONENT Examples
+- PATTERN "CVS" EXCLUDE
+- PATTERN ".svn" EXCLUDE
+- )
+-
+-
+ #-----------------------------------------------------------------------------
+ # Provide packaging with CPack.
+ include(Geant4CPackBase)
diff --git a/sci-physics/geant/files/geant-4.9.4-datadir.patch b/sci-physics/geant/files/geant-4.9.4-datadir.patch
new file mode 100644
index 000000000000..c691d90e8ce4
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-datadir.patch
@@ -0,0 +1,43 @@
+--- cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake.orig 2011-01-22 00:49:11.096082056 +0000
++++ cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake 2011-01-22 00:53:04.746078920 +0000
+@@ -74,9 +74,9 @@
+ # Construct backward compatible variables
+ #
+ set(G4SYSTEM "${GEANT4_SYSTEM}-${GEANT4_COMPILER}")
+-set(G4INSTALL ${GEANT4_DATADIR}/geant4-${geant4_VERSION})
++set(G4INSTALL ${GEANT4_DATADIR}/geant4)
+ set(G4INCLUDE ${GEANT4_INCLUDEDIR}/geant4)
+-set(G4LIB ${GEANT4_LIBDIR}/geant4-${geant4_VERSION})
++set(G4LIB ${GEANT4_LIBDIR}/geant4)
+
+ message(STATUS "Geant4 backwards compatible variable G4SYSTEM : ${G4SYSTEM}")
+ message(STATUS "Geant4 backwards compatible variable G4INSTALL: ${G4INSTALL}")
+@@ -125,7 +125,7 @@
+ # Install targets
+ # toolchain
+ install(DIRECTORY config
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
++ DESTINATION ${GEANT4_DATAROOTDIR}/geant4
+ FILES_MATCHING PATTERN "*.gmk"
+ PATTERN "CVS" EXCLUDE
+ PATTERN "scripts/" EXCLUDE)
+@@ -134,16 +134,16 @@
+ install(FILES
+ ${CMAKE_BINARY_DIR}/outputs/runtime/geant4-${geant4_VERSION}.sh
+ ${CMAKE_BINARY_DIR}/outputs/runtime/geant4-${geant4_VERSION}.csh
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}/config
++ DESTINATION ${GEANT4_DATAROOTDIR}/geant4/config
+ PERMISSIONS
+ OWNER_READ OWNER_WRITE OWNER_EXECUTE
+ GROUP_READ GROUP_EXECUTE
+ WORLD_READ WORLD_EXECUTE)
+
+ # compatibility softlink to library directory
+- install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E make_directory \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4-${geant4_VERSION})")
++ install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E make_directory \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4)")
+
+- install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E create_symlink .. ${GEANT4_SYSTEM}-${GEANT4_COMPILER} WORKING_DIRECTORY \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4-${geant4_VERSION})")
++ install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E create_symlink .. ${GEANT4_SYSTEM}-${GEANT4_COMPILER} WORKING_DIRECTORY \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4)")
+
+ endif()
+
diff --git a/sci-physics/geant/files/geant-4.9.4-libdir.patch b/sci-physics/geant/files/geant-4.9.4-libdir.patch
new file mode 100644
index 000000000000..8934f73acfe9
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-libdir.patch
@@ -0,0 +1,35 @@
+--- CMakeLists.txt.orig 2011-01-17 06:25:14.536078940 +0000
++++ CMakeLists.txt 2011-01-21 23:50:53.406082074 +0000
+@@ -195,7 +195,7 @@
+ set(GEANT4_PREFIX ${CMAKE_INSTALL_PREFIX})
+ set(GEANT4_EXEC_PREFIX ${GEANT4_PREFIX})
+ set(GEANT4_BINDIR ${GEANT4_EXEC_PREFIX}/bin)
+-set(GEANT4_LIBDIR ${GEANT4_PREFIX}/lib)
++set(GEANT4_LIBDIR ${GEANT4_PREFIX}/lib${LIB_SUFFIX})
+ set(GEANT4_DATAROOTDIR ${GEANT4_PREFIX}/share)
+ set(GEANT4_DATADIR ${GEANT4_DATAROOTDIR})
+ set(GEANT4_INCLUDEDIR ${GEANT4_PREFIX}/include)
+--- cmake/Modules/Geant4MacroLibraryTargets.cmake.orig 2011-01-21 23:36:09.356079013 +0000
++++ cmake/Modules/Geant4MacroLibraryTargets.cmake 2011-01-21 23:49:49.826082339 +0000
+@@ -35,8 +35,8 @@
+ # NEEDS WORK TO REMOVE HARDCODED LIB/BIN DIR
+ install(TARGETS ${G4LIBTARGET_NAME}
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ endif()
+
+ #
+@@ -59,8 +59,8 @@
+
+ install(TARGETS ${G4LIBTARGET_NAME}-static
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ endif()
+ ENDMACRO()
+
diff --git a/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch b/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch
new file mode 100644
index 000000000000..8c9d47707ac4
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch
@@ -0,0 +1,10 @@
+--- source/geometry/CMakeLists.txt.orig 2011-01-17 05:09:38.046080303 +0000
++++ source/geometry/CMakeLists.txt 2011-01-17 05:09:59.636215548 +0000
+@@ -12,7 +12,6 @@
+ #
+ #------------------------------------------------------------------------------
+
+-add_subdirectory(benchmarks)
+ add_subdirectory(biasing)
+ add_subdirectory(divisions)
+ add_subdirectory(magneticfield)
diff --git a/sci-physics/geant/files/geant-4.9.4-no-examples.patch b/sci-physics/geant/files/geant-4.9.4-no-examples.patch
new file mode 100644
index 000000000000..6db7b3f9017d
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-no-examples.patch
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2011-01-22 01:47:07.000000000 +0000
++++ CMakeLists.txt 2011-01-22 02:00:58.676084146 +0000
+@@ -209,9 +209,9 @@
+ # Install any extra files needed such as documentation and legacy Makefiles
+ #
+ # User example code
+-install(DIRECTORY examples
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
+- PATTERN "CVS" EXCLUDE)
++#install(DIRECTORY examples
++# DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
++# PATTERN "CVS" EXCLUDE)
+
+
+ #
diff --git a/sci-physics/geant/files/geant-4.9.4-trajectory.patch b/sci-physics/geant/files/geant-4.9.4-trajectory.patch
new file mode 100644
index 000000000000..df45ae234e50
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-trajectory.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2011-04-28 01:19:54.232041312 +0200
++++ CMakeLists.txt 2011-04-28 01:15:11.434101391 +0200
+@@ -43,6 +43,8 @@
+ set(${PROJECT_NAME}_VERSION_MINOR "4")
+ set(${PROJECT_NAME}_VERSION_PATCH "1")
+
++add_definitions(-DG4_STORE_TRAJECTORY)
++
+ #------------------------------------------------------------------------------
+ # Set up path to internal set of CMake modules.
+ #
diff --git a/sci-physics/geant/files/geant-4.9.4-zlib.patch b/sci-physics/geant/files/geant-4.9.4-zlib.patch
new file mode 100644
index 000000000000..f0429695ce38
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-zlib.patch
@@ -0,0 +1,35 @@
+force use of system zlib instead of bundled G4zlib
+--- source/visualization/HepRep/sources.cmake.orig 2011-12-02 15:07:49.000000000 +0000
++++ source/visualization/HepRep/sources.cmake 2011-12-18 06:21:22.000000000 +0000
+@@ -91,7 +91,7 @@
+ G4specsolids
+ G4tracking
+ G4vis_management
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ GLOBAL_DEPENDENCIES
+ G4digits_hits
+ G4geometry
+@@ -102,7 +102,7 @@
+ G4modeling
+ G4tracking
+ G4vis_management
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ LINK_LIBRARIES
+ )
+
+--- source/visualization/externals/gl2ps/sources.cmake.orig 2011-12-02 16:07:56.000000000 +0100
++++ source/visualization/externals/gl2ps/sources.cmake 2012-03-09 14:09:26.965148002 +0100
+@@ -49,9 +49,9 @@
+ G4OpenGL2PSAction.cc
+ gl2ps.cc
+ GRANULAR_DEPENDENCIES
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ GLOBAL_DEPENDENCIES
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ LINK_LIBRARIES
+ ${OPENGL_LIBRARIES}
+ )