summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-20 17:07:04 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-20 17:07:49 -0600
commit36ce5c81267a2880fd40e5d8e14c2c0122480083 (patch)
treeab21bafbec682a1734f5a7e04bf5b9be4096319f /sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
parentmate-extra/mate-screensaver: Drop old (diff)
downloadgentoo-36ce5c81267a2880fd40e5d8e14c2c0122480083.tar.gz
gentoo-36ce5c81267a2880fd40e5d8e14c2c0122480083.tar.bz2
gentoo-36ce5c81267a2880fd40e5d8e14c2c0122480083.zip
sci-physics/hoomd-blue: make 2.0.1 work without git
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-physics/hoomd-blue/hoomd-blue-9999.ebuild')
-rw-r--r--sci-physics/hoomd-blue/hoomd-blue-9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild b/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
index 5b01964b32c8..e126c82634de 100644
--- a/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
+++ b/sci-physics/hoomd-blue/hoomd-blue-9999.ebuild
@@ -7,31 +7,37 @@ EAPI=6
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit cmake-utils cuda flag-o-matic git-r3 python-single-r1
+inherit cmake-utils cuda flag-o-matic python-single-r1
DESCRIPTION="a general-purpose particle simulation toolkit"
HOMEPAGE="http://codeblue.umich.edu/hoomd-blue/"
EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
-if [[ ${PV} != 9999 ]]; then
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://bitbucket.org/glotzer/${PN}.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ GETTAR_VER=0.5.0
+ SRC_URI="https://bitbucket.org/glotzer/${PN}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2
+ https://bitbucket.org/glotzer/libgetar/get/v${GETTAR_VER}.tar.bz2 -> libgetar-${GETTAR_VER}.tar.bz2"
KEYWORDS="~amd64"
- EGIT_COMMIT="v${PV}"
fi
LICENSE="hoomd-blue"
SLOT="0"
-IUSE="cuda test mpi +zlib"
+IUSE="cuda test mpi"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
mpi? ( virtual/mpi )
cuda? ( dev-util/nvidia-cuda-sdk )
- zlib? ( sys-libs/zlib )
dev-libs/boost:=[threads,python,mpi,${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
src_prepare() {
+ [[ ${PV} = 9999 ]] || mv ../libgetar-${GETTAR_VER}/* hoomd/extern/libgetar || die
use cuda && cuda_src_prepare
cmake-utils_src_prepare
}
@@ -39,11 +45,11 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DENABLE_MPI=$(usex mpi)
- -DENABLE_DOXYGEN=OFF #$(
-DENABLE_CUDA=$(usex cuda)
-DBUILD_TESTING=$(usex test)
-DPYTHON_EXECUTABLE="${PYTHON}"
-DCMAKE_INSTALL_PREFIX=$(python_get_sitedir)
+ -DUPDATE_SUBMODULES=OFF
)
cmake-utils_src_configure
}